Bug 1007835 - ModeShape should use deltas for cluster replication
ModeShape should use deltas for cluster replication
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: CR1
: ---
Assigned To: Horia Chiorean
: QA-Closed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 08:34 EDT by Horia Chiorean
Modified: 2016-02-10 03:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 03:56:40 EST
Type: Task
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker MODE-1875 Blocker Closed ModeShape should use partial deltas when transferring data in a cluster 2014-02-18 07:56:37 EST

  None (edit)
Description Horia Chiorean 2013-09-13 08:34:07 EDT
Because of an older ISPN bug, ModeShape switched from sending partial documents to sending full documents across the wire, in the case of a replicated cluster configuration. Since EAP 6.1.1.GA uses Infinispan 5.2.7 which should've fixed this issue, we should change back to sending partial documents.
Comment 1 JBoss JIRA Server 2013-09-13 10:14:28 EDT
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-1875

Enabled delta-based cluster replication after validating it with ISPN 5.2.7.Final and JGroups 3.2.10.Final
Comment 2 JBoss JIRA Server 2013-09-13 15:05:13 EDT
Randall Hauch <rhauch@jboss.org> made a comment on jira MODE-1875

Rebased and merged into the 'master' branch. Leaving open until it can be cherry-picked into the '3.3.x-prod-ip6.0' branch.
Comment 5 belong 2013-09-17 21:41:46 EDT
I assume this is not an issue to be recorded in the Release Notes - setting to requires_doc_text- accordingly.
Comment 9 JBoss JIRA Server 2013-10-24 05:18:16 EDT
Randall Hauch <rhauch@jboss.org> updated the status of jira MODE-1875 to Closed

Note You need to log in before you can comment on or make changes to this bug.