Bug 1007836 - GUI spinner quantity is not displaying correct value for Instance based subscription
GUI spinner quantity is not displaying correct value for Instance based subsc...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Carter Kozak
John Sefler
:
Depends On:
Blocks: rhsm-rhel65
  Show dependency treegraph
 
Reported: 2013-09-13 08:36 EDT by Rehana
Modified: 2014-09-14 20:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:29:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rehana 2013-09-13 08:36:39 EDT
Description of problem:
Observed that the quantity spinner value is not updating its value afer auto-attaching and removing the previouly attach instance based subscription

Version-Release number of selected component (if applicable):
subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.26-1
subscription-manager: 1.9.5-1.git.0.64f1883.el6
python-rhsm: 1.9.4-1.git.0.cfef6c8.el6


How reproducible:
3/3

Steps to Reproduce:
1.Register and auto-attach subscription on the client

[root@rhel65nightly ~]# subscription-manager attach --auto
Installed Product Current Status:
Product Name: RAM Limiting Product
Status:       Subscribed

Product Name: Stackable with Awesome OS for x86_64 Bits
Status:       Subscribed

Product Name: Awesome OS Instance Server Bits
Status:       Subscribed

Product Name: Awesome OS Server Bits
Status:       Subscribed

2.[root@rhel65nightly ~]# subscription-manager list --consume 
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Stackable with Awesome OS for x86_64
Provides:          Stackable with Awesome OS for x86_64 Bits
SKU:               stackable-with-awesomeos-x86_64
Contract:          109
Account:           12331131231
Serial:            5311491505507057517
Pool ID:           8ac6a3624110b958014110ba524706c7
Active:            True
Quantity Used:     1
Service Level:     
Service Type:      
Status Details:    
Starts:            09/12/2013
Ends:              09/12/2014

Subscription Name: Awesome OS with unlimited virtual guests
Provides:          Awesome OS Server Bits
SKU:               awesomeos-virt-unlimited
Contract:          145
Account:           12331131231
Serial:            3187947289147988058
Pool ID:           8ac6a3624110b958014110ba50730620
Active:            True
Quantity Used:     1
Service Level:     
Service Type:      
Status Details:    
Starts:            09/12/2013
Ends:              09/12/2014

Subscription Name: Stackable with Awesome OS for x86_64
Provides:          Stackable with Awesome OS for x86_64 Bits
SKU:               stackable-with-awesomeos-x86_64
Contract:          108
Account:           12331131231
Serial:            2805814011392737732
Pool ID:           8ac6a3624110b958014110ba526106d1
Active:            True
Quantity Used:     1
Service Level:     
Service Type:      
Status Details:    
Starts:            09/12/2013
Ends:              09/12/2014

Subscription Name: RAM Limiting Package (4GB stackable)
Provides:          RAM Limiting Product
SKU:               ram-4gb-stackable
Contract:          175
Account:           12331131231
Serial:            1409216758141777161
Pool ID:           8ac6a3624110b958014110ba4ece0595
Active:            True
Quantity Used:     3
Service Level:     
Service Type:      
Status Details:    
Starts:            09/12/2013
Ends:              09/12/2014

Subscription Name: Awesome OS Instance Based (Standard Support)
Provides:          Awesome OS Instance Server Bits
SKU:               awesomeos-instancebased
Contract:          42
Account:           12331131231
Serial:            2169163096540944613
Pool ID:           8ac6a3624110b958014110ba55ff082b
Active:            True
Quantity Used:     1
Service Level:     Standard
Service Type:      L1-L3
Status Details:    
Starts:            09/12/2013
Ends:              09/12/2014

3.Remove instance based subscription from the client
[root@rhel65nightly ~]# subscription-manager remove --serial 2169163096540944613
Serial numbers successfully removed at the server:
   2169163096540944613
1 local certificate has been deleted.

4.Now search for subscription onGUI, by clicking on "Update" button , it lists the "Awesome OS Instance Based (Standard support)" but the quantity recommended was "0"

Actual results:
Available subscription listed "Awesome OS Instance Based (Standard support)" but the quantity recommended was "0"


Expected results:
Should display correct quantity value

Additional info:
This bug was observed when i had other produts installed along with "Awesome OS Instance Server bits"
Comment 1 Carter Kozak 2013-09-17 12:32:28 EDT
The bug here appears to be that everything that has a stacking_id is being counted in the quantity stack, not only _matching_ stacking_ids.
Comment 2 Carter Kozak 2013-09-19 14:54:48 EDT
commit c67def26a24c2a43c1133995ad08ed27d18bb86d
Author: ckozak <ckozak@redhat.com>
Date:   Tue Sep 17 11:57:02 2013 -0400

    1007836: calculate suggested quantity with only matching stacking_ids
Comment 5 Rehana 2013-10-08 02:18:32 EDT
Retested on rhel6.5 machine having multiple stacking subscriptions, observed that now the suggessted quantity is calculated correctly.

tested version:

subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.29-1
subscription-manager: 1.9.9-1.el6
python-rhsm: 1.9.6-1.el6

Hence moving this bug to verified.
Comment 6 errata-xmlrpc 2013-11-21 16:29:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html

Note You need to log in before you can comment on or make changes to this bug.