Bug 1007841 - Leak 16 MB of memory per connection opened
Leak 16 MB of memory per connection opened
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-gtk (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On: 1028637 1109397
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 08:45 EDT by Daniel Berrange
Modified: 2015-03-05 08:40 EST (History)
4 users (show)

See Also:
Fixed In Version: spice-gtk-0.22-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1007837
Environment:
Last Closed: 2015-03-05 08:40:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2013-09-13 08:45:39 EDT
spice-gtk copied the gtk-vnc coroutine_ucontext.c so suffers from this same flaw

+++ This bug was initially created as a clone of Bug #1007837 +++

Description of problem:
The ucontext coroutine implementation mmap()s 16 MB of memory for the coroutine stack, but fails to ever unmap it. This causes the stack to leak for each coroutine started

Version-Release number of selected component (if applicable):
gtk-vnc-0.5.2-2.el7

How reproducible:
Always


Steps to Reproduce:
1. Run demo program in https://bugzilla.gnome.org/show_bug.cgi?id=705827 it will consume memory until exhausted, then crash.
2.
3.
Comment 4 Marc-Andre Lureau 2014-07-08 11:47:39 EDT
please QA ack, this is included in rebase
Comment 8 errata-xmlrpc 2015-03-05 08:40:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0297.html

Note You need to log in before you can comment on or make changes to this bug.