Bug 1007856 - rebuild of postgresql-plparrot package against new postgresql version
rebuild of postgresql-plparrot package against new postgresql version
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: postgresql-plparrot (Show other bugs)
20
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Gerd Pokorra
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1007840
  Show dependency treegraph
 
Reported: 2013-09-13 09:03 EDT by Pavel Raiskup
Modified: 2013-10-04 11:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-20 03:14:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Raiskup 2013-09-13 09:03:39 EDT
We have prepared update to new version of PostgreSQL package in Fedora 20
(postgresql-9.3.0-1.fc20 [1]).  According to the repoquery, package
'postgresql-plparrot' delivers postgresql plugin in %_libdir/pgsql directory.  This may
require rebuilding of the package.  If it is the case, it would be nice
to have prepared update of 'postgresql-plparrot' as soon as possible to be able to
deliver newer build in Fedora 20 Beta Release.  Otherwise, if the package
in reality does not need to be rebuild, close this bug as NOTABUG.

If your plugin really requires regular rebuild against new versions of
PostgreSQL, consider adding versioned runtime requirement on postgresql.

[1] https://admin.fedoraproject.org/updates/FEDORA-2013-16398/postgresql-9.3.0-1.fc20
Comment 1 Gerd Pokorra 2013-09-20 03:14:27 EDT
There was a build problem in f20. I fixed it.

The plugin do not requires regular rebuild against new versions of
PostgreSQL.
Comment 2 Pavel Raiskup 2013-09-20 09:15:08 EDT
(In reply to Gerd Pokorra from comment #1)
> There was a build problem in f20. I fixed it.

Thanks for looking into it.

> The plugin do not requires regular rebuild against new versions of
> PostgreSQL.

I really doubt that this is truth.  You should rebuild PostgreSQL plugins in
case of major version bump of server.  Otherwise, server prints something
like:

    psql:.../.....sql:XX: ERROR:  incompatible library
    "/usr/lib64/pgsql/PLUGIN.so": version mismatch DETAIL:  Server is version 9.3,
    library is version 9.2.

.. if you try to use the plugin.  I was unable to test it, though, due
to bug #1010295.

Pavel
Comment 3 Gerd Pokorra 2013-10-04 10:58:20 EDT
Hey,

currently I build parrt-5.5.0 on rawhide. So I have to rebuild postgresql-plparrot.

http://koji.fedoraproject.org/koji/taskinfo?taskID=6024672

What and how do I have to specify the version:


Current:
BuildRequires:  postgresql-devel
BuildRequires:  parrot-devel
Requires:       postgresql-server
Requires:       postgresql-contrib


BuildRequires:  postgresql-devel = ???
BuildRequires:  parrot-devel = ???
Requires:       postgresql-server = ???
Requires:       postgresql-contrib = ???


What do I have for specify for F19 and F20?

How do I notice when I have to rebuild against a new postgres version?

Gerd
Comment 4 Pavel Raiskup 2013-10-04 11:29:11 EDT
> currently I build parrt-5.5.0 on rawhide. So I have to rebuild
> postgresql-plparrot.
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=6024672
> 
> What and how do I have to specify the version:

For now I would use this:

# empty, or >= lowest major version you are able to build the package against
BuildRequires:  postgresql-devel = ???
# empty, or >= lowest major version you are able to build the package against
BuildRequires:  parrot-devel = (d
# Cut to only working server major version, example for FC20+
Requires: postgresql-server = postgresql-server >= 9.3, postgresql-server < 9.4
# I'm not sure you need this package?
Requires:       postgresql-contrib = ???

> What do I have for specify for F19 and F20?

Always that postgresql-server you are building against == if that is in
brewroot, it is also in relevant fedora release.

> How do I notice when I have to rebuild against a new postgres version?

You'll not.  Using that mechanism, you are not allowed update
postgresql-server without updating also plugin & vice-versa.

I tried to semi-automatize this by bug #1008939 - if that solution happens,
I'll ping you.

Thanks for working on this!  Pavel

Note You need to log in before you can comment on or make changes to this bug.