Bug 100786 - DateManip needs to use zoneinfo database for source of timezones
DateManip needs to use zoneinfo database for source of timezones
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-DateManip (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
: FutureFeature, Reopened
: 174984 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-25 09:14 EDT by James Olin Oden
Modified: 2008-03-21 05:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-21 05:38:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Olin Oden 2003-07-25 09:14:29 EDT
Description of problem:
Right now DateManip keeps an internal list of timezones.  This list as you
might expect is incomplete.  Instead of keeping an internal list it should
get its list from the zoneinfo database. This way it would agree with 
RedHat on what time zones are supported.  

As an example, if you set your time zone to America/Sao_Paulo, then
and then use this lib you will get a an error that causes your script 
to die something like:

   ERROR: Date::Manip unable to determine TimeZone.  
   Date::Manip::Date_TimeZone called 
at /usr/lib/perl5/vendor_perl/5.8.0/Date/Manip.pm line 629     

Newer versions of the library actually do include other time zones
(including Sao_Paulo), but the underlying problem is not fixed.
I have talked with Sullivan Beck (sbeck@cpan.org) the author of the
software and he is working on getting it to read the zone_info 
database, but it is not complete yet.

Version-Release number of selected component (if applicable):
5.40-30

How reproducible:
Always

Steps to Reproduce:
1.  Set timezone to Sao_Paulo with timeconfig.
2.  Run script that uses DateManip's UnixDate() function.
    
Actual results:

See above.

Expected results:

No problems.

Additional info:

Here is the email I got back from Sullivan Beck:

   > Hi Sullivan,
   >
   > I having been using your Date::Manip program and ran into a problem
   > when we deployed our software (and of yours) in Brazil.  We set the time
   > zone to Sao Paolo, and found that the timezones for it were not in your
   > libraries internal list of timezones.  Now, I downloaded the your latest
   > library and it does indeed have these entries in the list.  This fixes
   > that problem, but I was thinking of a way by which you would not have
   > to maintain an internal list.
   >
   > What I would like to see happen is at build time, a scan of the systems
   > tz/zoneinfo database be done, and your internal list would be generated
   > from that.  I have been trying to find out how to read these files to get
   > the offsets and abreviations out of them but I have not found how to yet
   > (otherwise you would be receiving a patch from me (-;).

   This is already in the works.  I will be using the tzdata database (which
   is the foundation for almost all other timezone databases).  In addition,
   I will probably add the ability to define additional timezone's as needed.

   BTW, trying to read the files is HARD.  The tzdata databases use some
   fairly complicated methods to store the information, and it's very
   non-trivial to convert it to something usable.  The majority of entries
   aren't that hard, but they had to add all kinds of special cases for the
   more bizarre methods that are used in some places.

   Anyway, Date::Manip 6.00 (which is coming sometime) will feature this.

   --------------------------|  Sullivan Beck  |---------------------------
   mailto:sbeck@cise.ufl.edu          |            Senior System Programmer
   http://www.cise.ufl.edu/~sbeck     |               University of Florida
   PH : (352) 392-1057                |                     CISE Department
   Fax: (352) 392-1220                |                            CSE 314E
   |         Gainesville, FL  32611-6120
   ------------------------------------------------------------------------
Comment 1 Warren Togami 2005-05-31 00:49:31 EDT
Is this still an issue in FC4?
Comment 2 Jason Vas Dias 2006-03-15 19:38:11 EST
*** Bug 174984 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2006-10-18 14:05:33 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.
Comment 4 Robin Norwood 2006-11-09 17:13:56 EST
This is still an issue in FC6.  Reopening.
Comment 5 Marcela Mašláňová 2008-03-21 05:38:57 EDT
It seems to be working at least in F-9. If the problem persist please feel free
to reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.