Bug 1007865 - After installation of net-snmp-devel-5.5-44.el6_4.4.x86_64 the command '$ man snmp_read' fails
Summary: After installation of net-snmp-devel-5.5-44.el6_4.4.x86_64 the command '$ man...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides   
(Show other bugs)
Version: 6.4
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Jan Chaloupka
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Keywords: ManPageChange, Patch
Depends On:
Blocks: 1119567
TreeView+ depends on / blocked
 
Reported: 2013-09-13 13:14 UTC by Leopold Aichinger
Modified: 2014-10-14 07:26 UTC (History)
4 users (show)

Fixed In Version: man-pages-overrides-6.6.2-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: man page for snmp_read was missing Consequence: man pages were missing Fix: missing man pages added Result: man snmp_read does not fail
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 07:26:19 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1382 normal SHIPPED_LIVE man-pages-overrides bug fix update 2014-10-14 01:21:54 UTC

Description Leopold Aichinger 2013-09-13 13:14:33 UTC
Description of problem:
After installation of the package net-snmp-devel-5.5-44.el6_4.4.x86_64.rpm
the command:
$ man snmp_read
fails with:
Cannot open man page /usr/share/man/man3/snmp_api.3.gz
No manual entry for snmp_read

but:
$ test -f /usr/share/man/man3/snmp_read.3.gz && echo "file exits"
file exits

$ zcat /usr/share/man/man3/snmp_read.3.gz
.so man3/snmp_api.3

$ test -f /usr/share/man/man3/snmp_api.3.gz && echo "file exits"
$


Version-Release number of selected component (if applicable):
5.5-44.el6_4.4

How reproducible:
Always

Steps to Reproduce:
1. yum install net-snmp-devel
2. man snmp_read



Actual results:


Expected results:


Additional info:
no result from:
rpm -ql net-snmp-devel | grep snmp_api.3.gz
conclusion:
link/file snmp_api.3.gz is missing in the rpm-package net-snmp-devel
In my opinion there should be a softlink snmp_api.3.gz to netsnmp_session_api.3.gz, or the content of the snmp_read.3.gz should be corrected to snmp_session_api.3

Comment 2 Jan Safranek 2013-09-19 11:08:43 UTC
Thanks for the report. You are correct, few man pages reference non-existing snmp_api.3. We'll fix it eventually, please go through Red Hat Support at access.redhat.com to speed things up.

Comment 13 errata-xmlrpc 2014-10-14 07:26:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1382.html


Note You need to log in before you can comment on or make changes to this bug.