This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1007874 - 'Create New' modal window improvements
'Create New' modal window improvements
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity medium
: ER5
: 6.0.0
Assigned To: Mauricio Salatino
Zuzana Krejčová
:
Depends On:
Blocks: bpms6_ux/brms6_ux
  Show dependency treegraph
 
Reported: 2013-09-13 09:31 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:19:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modal window with problematic parts (41.34 KB, image/png)
2013-09-13 09:31 EDT, Zuzana Krejčová
no flags Details
improvements to the create new screen (35.68 KB, image/png)
2013-10-10 18:54 EDT, Mauricio Salatino
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-09-13 09:31:49 EDT
Created attachment 797337 [details]
modal window with problematic parts

Description of problem:
The modal window for creating a new resource is unnecessarily complicated.

1. You have already chosen the resource type to be created, there is no need to offer the choice again. User should choose the resource type just once, the modal window should not contain this option.

2. If there is no option to change the resource type, the title should be changed to New <type> for the type selected instead of New resource.

3. The window has 2 'titles', one is 'Create new', the other below that is 'New resource' (or later perhaps New <type> for the selected type). It might look better to only mention the 'New' once or have only one title.

4. The path (default://master@uf-playground/defaultPackage/src/main/resources) probably wont say much to the business user. But we should probably get more opinions on this.

5. There is a lot of empty space below the path.
Comment 5 Mauricio Salatino 2013-10-10 18:54:28 EDT
Created attachment 810824 [details]
improvements to the create new screen
Comment 6 Mauricio Salatino 2013-10-10 19:14:39 EDT
Does the attached popup looks better? It is way better IMO, there are a lot of things that needs to be improved yet, but this is just the first step. 
Notice that the footer is looking weird because it is not defined inside the Create New Resource screen. We can open another BZ to cover that. 

Pushed to 6.0.x
Comment 7 Zuzana Krejčová 2013-10-14 02:46:07 EDT
(In reply to Mauricio Salatino from comment #6)
> Does the attached popup looks better? It is way better IMO, there are a lot
> of things that needs to be improved yet, but this is just the first step. 
> Notice that the footer is looking weird because it is not defined inside the
> Create New Resource screen. We can open another BZ to cover that. 
> 
> Pushed to 6.0.x

It's definitely a lot better, thanks.

Note You need to log in before you can comment on or make changes to this bug.