Bug 1007907 - xorg takes even 50% of the CPU during the installation phase
xorg takes even 50% of the CPU during the installation phase
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 10:29 EDT by Ales Kozumplik
Modified: 2014-09-30 19:41 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-27 10:50:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Kozumplik 2013-09-13 10:29:49 EDT
Description of problem:
In a KVM machine, xorg takes 40%-50% CPU the whole time the Yum payload is installing the packages. This renders the machine very slow (e.g. to fill in the root password)

Additional info:
This could be because of busy waiting somewhere or a misuse of X by one of the Anaconda components.
Comment 1 Ales Kozumplik 2013-09-13 10:30:50 EDT
(reproduced on the f20 devel compose circa 0908)
Comment 2 Vratislav Podzimek 2013-09-23 11:18:58 EDT
Could you still reproduce this with some F20 Alpha image? It works for me, Xorg takes something between 1 and 10 % of CPU, usually 1 %. Unless we have a reproducer with a recent image I'm gonna close this bug as WORKSFORME.
Comment 3 Ales Kozumplik 2013-09-27 04:59:35 EDT
Please point me to a working F20 image. Just tried with:

http://download.eng.brq.redhat.com/pub/fedora/linux/development-snapshot-20130926/20/

And anaconda hangs taking 100% of the CPU.
Comment 5 Ales Kozumplik 2013-09-27 09:52:42 EDT
I see Xorg at around 10-15% during the installation which I guess is fine (by today's Fedora standards). Please go ahead closing it.

Note You need to log in before you can comment on or make changes to this bug.