Bug 1007911 - kernel-3.11.0-300.fc20 fails to find the rootfs in qemu
kernel-3.11.0-300.fc20 fails to find the rootfs in qemu
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
arm Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kyle McMartin
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-09-13 10:35 EDT by Paul Whalen
Modified: 2015-08-31 23:54 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 11:13:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel-3.11.0-300.fc20 boot on qemu (13.06 KB, text/plain)
2013-09-13 10:35 EDT, Paul Whalen
no flags Details

  None (edit)
Description Paul Whalen 2013-09-13 10:35:28 EDT
Created attachment 797373 [details]
kernel-3.11.0-300.fc20 boot on qemu

Description of problem:
As of kernel-3.11.0-300.fc20 vexpress emulation in 'qemu-system-arm' fails to find the root filesystem and drops to dracut. Last working kernel is 'kernel-3.11.0-3.fc20'.
Comment 1 Josh Boyer 2013-09-13 11:36:38 EDT
Thanks for opening the bug Paul.  I started a scratch build with the BBB patches removed.  Testing that would be step one I guess.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5931688

The only other change that looks relevant is the disabling of CONFIG_PCIEPORTBUS to fix the tegra issues.  So if the scratch build above doesn't work, we can go there next I suppose.
Comment 2 Paul Whalen 2013-09-16 11:13:31 EDT
kernel-3.11.0-300.fc20 now boots without issue in qemu-system-arm. There was an update to a number of packages including qemu(qemu-system-arm-1.4.2-9.fc19). Closing this bug.
Comment 3 Peter Robinson 2013-09-18 23:24:27 EDT
I noticed there was this fix on qemu, not sure if it was related 

commit 829f9fedee30cde2ec15e88d57ec11074db791e2
Author: Peter Maydell <peter.maydell@linaro.org>
Date:   Thu Aug 22 17:47:49 2013 +0100

    ARM: PCI: versatile: Fix PCI I/O
    
    The versatile PCI controller code was confused between the
    PCI I/O window (at 0x43000000) and the first PCI memory
    window (at 0x44000000). Pass the correct base address to
    pci_remap_io() so that PCI I/O accesses work.
    
    Since the first PCI memory window isn't used at all (it's
    an odd size), rename the associated variables and labels
    so that it's clear that it isn't related to the I/O window.
    
    This has been tested and confirmed to fix PCI I/O accesses
    both on physical PB926+PCI backplane hardware and on QEMU.
    
    Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
    Cc: stable@vger.kernel.org
    Reviewed-by: Linus Walleij <linus.walleij@linaro.org>
    Signed-off-by: Kevin Hilman <khilman@linaro.org>

Note You need to log in before you can comment on or make changes to this bug.