Bug 100792 - Read only disk image apparently writable to
Read only disk image apparently writable to
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
http://www-1.ibm.com/servers/eserver/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-25 11:15 EDT by Paul Nasrat
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-13 17:11:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Nasrat 2003-07-25 11:15:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I was attempting to install supplemental packages in order to build and test my
s390 package.  I saw /usr and /usr/share were ro, so I remounted them rw.

mount -o rw,remount /usr worked for me, and things were written
successfully, were runable and then vanished or corrupted.

Conversation with LINUXATS@us.ibm.com

"This mount point is read only because it is shared between all users of the
same distribution. This mount point is mounted read-only by VM and can not be
changed by the user. It may appear that you can change it by altering the fstab
in your linux instance, however as I mentioned earlier VM has it mounted to your
instance as read only and altering the linux fstab will not over ride it."


Version-Release number of selected component (if applicable):
kernel-2.4.9-38

How reproducible:
Always

Steps to Reproduce:
1. create a large file system in one of the rw partitions ( in this case  / )
2.  ensure files are correct type, etc - file blah, md5sum blah
3.  remount a ro disk image rw
4.  sync data across I tried mv/cp/tar cf - . | ( cd/wherever; tar xvf -)/rsync.
5.  test files
6.   reboot

Actual Results:  Data "corrupted" (wrong file type etc).  This is due to inode
cache filling up with large transfer I guess.

Not present after reboot

Expected Results:  Not be able to mount rw - can someone clarify if the dasd
driver has enough information about an image to fail to mount rw

Additional info:


[root@l005068 home]# du -h -s /home/pauln/
126M    /home/pauln

[root@l005068 home]# cat /proc/meminfo
        total:    used:    free:  shared: buffers:  cached:
Mem:  124186624 69189632 54996992        0 22958080 22847488
Swap:        0        0        0
MemTotal:       121276 kB
MemFree:         53708 kB
MemShared:           0 kB
Buffers:         22420 kB
Cached:          22312 kB
SwapCached:          0 kB
Active:          44092 kB
Inact_dirty:       640 kB
Inact_clean:         0 kB
Inact_target:    32768 kB
HighTotal:           0 kB
HighFree:            0 kB
LowTotal:       121276 kB
LowFree:         53708 kB
SwapTotal:           0 kB
SwapFree:            0 kB

rsync -avP /home/pauln /usr/share/

[root@l005068 SOURCES]# file IBMJava2-SDK-131.s390.tgz
IBMJava2-SDK-131.s390.tgz: ASCII text, with no line terminators
[root@l005068 SOURCES]# file /home/pauln/rpm/SOURCES/IBMJava2-SDK-131.s390.tgz
/home/pauln/rpm/SOURCES/IBMJava2-SDK-131.s390.tgz: gzip compressed data,
deflated, last modified: Tue Jun 17 23:17:46 2003, os: Unix

You get following kernel messages:

Sense data:
dasd(eckd):device 1017 on irq 12: I/O status report:
dasd(eckd):in req: 06e86f00 CS: 0x00 DS: 0x02
dasd(eckd):Failing CCW: 06e86fa0
dasd(eckd):Sense(hex)  0- 7: 80 02 00 00 00 00 00 00
dasd(eckd):Sense(hex)  8-15: 00 00 00 00 00 00 00 00
dasd(eckd):Sense(hex) 16-23: 00 00 00 00 00 f1 0f 00
dasd(eckd):Sense(hex) 24-31: 00 00 40 e2 00 00 00 00
dasd(eckd):24 Byte: 0 MSG 0, no MSGb to SYSOP
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:(EXAMINE) ERP chain report for req:
06e86f00
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:06e86f00: c5c3d2c4 00000000 0096ff00
06e86800
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:06e86f10: 00964000 00933a00 06e86f90
03000002
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:06e86f20: 00000000 ff000000 06e86f70
00000000
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:06e86f30: 00000000 00000000 0000011e
1a300000
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:06e86f40: b9c59e15 2b96f0c6 b9c59e15
2b96fa46
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:06e86f50: 00000000 00000000 00000000
00000000
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:06e86f60: 00000004 00000020 0099cc70
00000000
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:Channel program (complete):
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:06e86f90: 63400010 06e86f70 47400010
06e86f80
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:06e86fa0: 85001000 03310000 00000000
00000000
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:06e86fb0: 00000000 00000000 00000000
00000000
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:06e86fc0: 00000000 00000000 00000000
00000000
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:Failed CCW (06e86fa0) already logged
end_request: I/O error, dev 5e:09 (dasd), sector 224
dasd_erp(3990): /dev/dasdc(94:8),1017@0xc:EXAMINE 24: Command Reject detected -
fatal error
Comment 1 Florian La Roche 2003-08-13 17:11:57 EDT
The mainframe kernel used to have a bug where read-only dasd's have not been
read-only for the Linux kernel. Fixed with nwer kernel's as in the Taroon beta
of our upcoming RHEL3 release.

greetings,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.