Bug 1007926 - Bash outputs functions with multi-line here-strings incorrectly
Bash outputs functions with multi-line here-strings incorrectly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bash (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ondrej Oprala
Martin Frodl
:
Depends On:
Blocks: 1116299 1116303
  Show dependency treegraph
 
Reported: 2013-09-13 10:56 EDT by Nikolai Kondrashov
Modified: 2014-10-14 03:09 EDT (History)
5 users (show)

See Also:
Fixed In Version: bash-4.1.2-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1116299 1116303 (view as bug list)
Environment:
Last Closed: 2014-10-14 03:09:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bash-4.1-multiline_heredoc.patch (4.24 KB, patch)
2014-02-20 10:53 EST, pstodulk
no flags Details | Diff

  None (edit)
Description Nikolai Kondrashov 2013-09-13 10:56:59 EDT
Description of problem:
Bash includes quotes used in multi-line here-strings into the function output produced with "declare" or "set", thus corrupting the declaration. This breaks, for example, copying functions under another name, or transferring them to another shell.

Version-Release number of selected component (if applicable):
bash-4.1.2-15.el6_4.x86_64

How reproducible:
Always

Steps to Reproduce:
Execute the following:
bash -c 'f() { cat <<<"line1'$'\n''line2"; }; declare -f f'

Actual results:
f () 
{ 
    cat <<< $'"line1\nline2"'
}

Expected results:
f () 
{ 
    cat <<< "line1
line2"
}

Additional info:
This works on RHEL7 with bash-4.2.45-2.el7.x86_64.
Comment 1 Nikolai Kondrashov 2013-09-13 11:08:56 EDT
Sorry, the first sentence of the description is unclear and incorrect. I'll try to rephrase.

The problem is that bash quotes the quotes used in multi-line here-strings in the printed functions, thus including them into the resulting here-string.
Comment 3 pstodulk 2014-02-20 10:53:53 EST
Created attachment 865588 [details]
bash-4.1-multiline_heredoc.patch

Patch in attachment created from "print_cmd.c" in bash-4.2.
Comment 4 Branislav Náter 2014-05-30 05:03:37 EDT
Reproducer available, qa_ack+ for rhel-6.6
Comment 7 errata-xmlrpc 2014-10-14 03:09:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1503.html

Note You need to log in before you can comment on or make changes to this bug.