Bug 1007941 - pkg-config file requires openni-dev, which has no pkg-config file
pkg-config file requires openni-dev, which has no pkg-config file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pcl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rich Mattes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 11:25 EDT by Volker Fröhlich
Modified: 2013-09-26 02:04 EDT (History)
2 users (show)

See Also:
Fixed In Version: pcl-1.7.0-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-26 02:04:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Volker Fröhlich 2013-09-13 11:25:06 EDT
Description of problem:

The pkg-config file that ships with pcl requires "openni-dev". openni ships no pkg-config file though -- neither upstream nor Fedora. Consequently, if you're using pcl's pkg-config file, it can't fulfill the requirements and that's causing issues with dependent builds, like gtatool, for instance.


Version-Release number of selected component (if applicable):

It's certainly a problem with 1.7.
Comment 1 Rich Mattes 2013-09-13 21:42:47 EDT
Whoops, looks like the ROS deb of OpenNI has a .pc file added that isn't upstream.  I'll remove it from pcl's pkgconfig for now
Comment 2 Fedora Update System 2013-09-14 16:40:55 EDT
pcl-1.7.0-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pcl-1.7.0-4.fc20
Comment 3 Fedora Update System 2013-09-15 13:36:14 EDT
Package pcl-1.7.0-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pcl-1.7.0-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16781/pcl-1.7.0-4.fc20
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-09-26 02:04:14 EDT
pcl-1.7.0-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.