Bug 1007956 - config.{guess,sub} need to be updated to get it buildable on AArch64 architecture
config.{guess,sub} need to be updated to get it buildable on AArch64 architec...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ncbi-blast+ (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Kaluža
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 11:46 EDT by Marcin Juszkiewicz
Modified: 2013-10-04 01:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-04 01:43:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for a bug (1.66 KB, patch)
2013-09-13 11:51 EDT, Marcin Juszkiewicz
no flags Details | Diff

  None (edit)
Description Marcin Juszkiewicz 2013-09-13 11:46:32 EDT
Description of problem:

ncbi-blast+ for some reasons do not use %configure macro. Part of this macro updates config.{guess,sub} files to the latest ones to get support for all new architectures (AArch64 in our case).

Version-Release number of selected component (if applicable):

2.2.28-1

How reproducible:

always

Steps to Reproduce:
1. fetch source rpm
2. rebuild for AArch64


Actual results:

~/rpmbuild/BUILD/ncbi-blast-2.2.28+-src/c++ ~/rpmbuild/BUILD/ncbi-blast-2.2.28+-src
+ ./configure --with-dll --with-mt --without-autodep --without-makefile-auto-update --with-flat-makefile --without-caution --without-dbapi --without-lz
o --with-runpath=/usr/lib64/ncbi-blast+ --with-build-root=BUILD
configure: loading site script ./src/build-system/config.site

configure: creating cache config.cache
checking build system type... src/build-system/config.guess: unable to guess system type

This script, last modified 2003-02-22, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from

    ftp://ftp.gnu.org/pub/gnu/config/



Expected results:

+ ./configure --with-dll --with-mt --without-autodep --without-makefile-auto-update --with-flat-makefile --without-caution --without-dbapi --without-lz
o --with-runpath=/usr/lib64/ncbi-blast+ --with-build-root=BUILD
configure: loading site script ./src/build-system/config.site

configure: creating cache config.cache
checking build system type... aarch64-unknown-linux-gnu
checking host system type... aarch64-unknown-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking for gcc... gcc
checking for C compiler default output file name... a.out
Comment 1 Marcin Juszkiewicz 2013-09-13 11:51:09 EDT
Created attachment 797413 [details]
fix for a bug
Comment 2 Marcin Juszkiewicz 2013-09-13 11:52:12 EDT
I am still waiting for build to finish.
Comment 3 Jan Kaluža 2013-09-13 16:14:40 EDT
Hm, seeing this I think i will try harder to patch ncbi-blast to support Fedora's %configure macro. If it will be really hard and big patch, then I will use your proposed patch.
Comment 4 Jan Kaluža 2013-10-03 08:00:30 EDT
I have just fixed this in rawhide. Correct me if I'm wrong, but you need only proper .spec file in git repository, so I don't have to build and create update for F19/F20, right?
Comment 5 Marcin Juszkiewicz 2013-10-03 09:28:13 EDT
You do not have. If we will build it for F19/AArch64 then we can extract changes.
Comment 6 Jan Kaluža 2013-10-04 01:43:09 EDT
OK, I have pushed the fix into f19 and f20 git repository. I will close this bug, since there's nothing more I can do right now.

Note You need to log in before you can comment on or make changes to this bug.