Bug 1007971 - Decision logic design should be more intuitive
Decision logic design should be more intuitive
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium
: ER 7
: 6.0.0
Assigned To: Pere Fernàndez
Radovan Synek
:
Depends On:
Blocks: bpms6_ux/brms6_ux
  Show dependency treegraph
 
Reported: 2013-09-13 12:10 EDT by Radovan Synek
Modified: 2014-08-06 16:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:12 EDT
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshots from Polymita (425.00 KB, application/vnd.oasis.opendocument.text)
2013-10-17 09:44 EDT, Pedro Zapata
no flags Details
Short term specs (73.30 KB, application/vnd.oasis.opendocument.text)
2013-10-18 10:40 EDT, Pedro Zapata
no flags Details
Long term specs (175.60 KB, application/vnd.oasis.opendocument.text)
2013-10-18 10:42 EDT, Pedro Zapata
no flags Details
UI proposal for short term solution (72.00 KB, image/png)
2013-10-24 14:00 EDT, Joe Sniezek
no flags Details

  None (edit)
Description Radovan Synek 2013-09-13 12:10:11 EDT
Ideas:
- what about enhancing code assistance with typical operators: equals, lesser than, not equal to, greater than, ...?

- to simplify condition expression on sequence flow: only single line expression, no "return" keyword, no ";". More complex script should go to script task or service task, I believe these conditions on seq. flow are supposed to be just expressions operating over process variables.

this simplification is connected with bug 1007760
Comment 1 Prakash Aradhya 2013-09-15 23:16:48 EDT
Yes, this is a blocker for GA.  This needs to be fixed with better UI option. We can live without this for Beta
Comment 2 Kris Verlaenen 2013-09-16 11:15:46 EDT
I would consider this a feature request, not a bug.
Comment 3 Prakash Aradhya 2013-09-16 21:29:07 EDT
Kris,
It is arguable it is a feature.  But asking end user to enter java code is simply not expected.  The fundamental goal of this release is to build the tool that is comfortable for business users to design processes with little to no help from IT.

Its a must fix for GA.  Please estimate the effort needed to fix this issue.
I suggest we leverage the UI that already exists in polymita code.  I am not sure how much of that is reusable.  But atleast there is an example hat we can use.

Internal Whiteboard: Beta Blocker → Blocker
Not critical for Beta, but need to address for GA
Comment 4 Joe Sniezek 2013-10-07 16:39:13 EDT
Could someone provide screenshots of the what this looks like for BPMS vs. Polymita?
Comment 5 Pedro Zapata 2013-10-17 09:44:56 EDT
Created attachment 813336 [details]
Screenshots from Polymita

Screenshots from Polymita expression builder
Comment 6 Pedro Zapata 2013-10-18 10:40:58 EDT
Created attachment 813800 [details]
Short term specs

Specs for a very limited subset of this feature to be developed in short term
Comment 7 Pedro Zapata 2013-10-18 10:42:51 EDT
Created attachment 813801 [details]
Long term specs
Comment 8 Joe Sniezek 2013-10-24 14:00:31 EDT
Created attachment 815876 [details]
UI proposal for short term solution
Comment 10 Pedro Zapata 2013-11-22 05:52:00 EST
The latest review in 6.0.x showed some browser related problems in Google Chrome. There are differences in Javascript behaviour that needs a further review.
Comment 11 Pere Fernàndez 2013-11-22 06:46:04 EST
Changed panel layout to avoid that the inputs are displayed when an action is selected. 

Commits master: https://github.com/droolsjbpm/jbpm-designer/commit/bf4b583618e70b7b9819c3d805b76bc51473d19f

Commits 6.0.x: https://github.com/droolsjbpm/jbpm-designer/commit/7bee13ea00cf8df689a1f34074bcb7c25c3dfc67
Comment 12 Radovan Synek 2014-01-09 07:02:47 EST
Verified with BPMS-6.0.0.ER7 (Firefox, Google Chrome)

Note You need to log in before you can comment on or make changes to this bug.