Bug 1007979 - Recovery alert is lost across JON server restart
Recovery alert is lost across JON server restart
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Monitoring - Alerts (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ER07
: JON 3.2.0
Assigned To: Lukas Krejci
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 12:32 EDT by Larry O'Leary
Modified: 2014-01-02 15:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry O'Leary 2013-09-13 12:32:35 EDT
Description of problem:
If an alert is disabled by an alert condition and the JBoss ON server is restarted prior to the recovery alert that is to re-enabled the disabled alert being fired, the recovery alert will never get fired.

The result is that the original alert remains disabled until the user manually re-enables it.

Version-Release number of selected component (if applicable):
4.9.0-SNAPSHOT Build Number=[1882507]

How reproducible:
Always

Steps to Reproduce:
1. Add a "goes down" alert with recovery disabled set
2. Add a "goes up" alert with recovery of alert created in previous step
3. Shutdown the resource that the "goes down" alert is set on
4. Verify "goes down" alert was triggered and is now disabled
5. Restart the JBoss ON server
6. Start the resource that the "goes up" alert is set on

Actual results:
"goes down" alert is never recovered and re-enabled.

Expected results:
"goes up" alert should recover "goes down" alert if condition is true when server comes back up or becomes true after server comes back up and "goes down" alert should be enabled.
Comment 1 Lukas Krejci 2013-11-20 11:16:29 EST
Couldn't reproduce in release branch post ER6 and pre ER7.
Comment 2 Sunil Kondkar 2013-12-02 10:02:31 EST
Verified on version : 3.2.0.ER7 Build Number : e8e6401:ff0061d

Followed the steps and verified that "goes down" alert is re-enabled.

Note You need to log in before you can comment on or make changes to this bug.