Bug 1008008 - autokey-gtk fails to run
autokey-gtk fails to run
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: autokey (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Raghu Udiyar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 14:48 EDT by Jay Guerette
Modified: 2013-09-24 18:52 EDT (History)
1 user (show)

See Also:
Fixed In Version: autokey-0.90.4-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 18:52:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Guerette 2013-09-13 14:48:46 EDT
Description of problem:

Version-Release number of selected component (if applicable):
autokey-gtk-0.90.4-3.fc19.noarch

How reproducible:
100%

Steps to Reproduce:
1.run autokey-gtk from terminal
2.observe error message
3.sigh disappointedly
  
Actual results:
prints "gi.RepositoryError: Requiring namespace 'Gtk' version '2.0', but '3.0' is already loaded" and exits

Expected results:
runs

Additional info:

Error output

Traceback (most recent call last):
  File "/bin/autokey-gtk", line 20, in <module>
    from autokey.gtkapp import Application
  File "/usr/lib/python2.7/site-packages/autokey/gtkapp.py", line 31, in <module>
    from gtkui.configwindow import ConfigWindow
  File "/usr/lib/python2.7/site-packages/autokey/gtkui/configwindow.py", line 20, in <module>
    from gi.repository import Gtk, Pango, GtkSource, Gdk, Gio
  File "/usr/lib64/python2.7/site-packages/gi/importer.py", line 68, in load_module
    dynamic_module._load()
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 289, in _load
    self._introspection_module = get_introspection_module(self._namespace)
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 268, in get_introspection_module
    module = IntrospectionModule(namespace, version)
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 117, in __init__
    repository.require(namespace, version)
gi.RepositoryError: Requiring namespace 'Gtk' version '2.0', but '3.0' is already loaded

This is the same as Bug 953966 for Fedora 17
Comment 1 Raghu Udiyar 2013-09-13 14:54:39 EDT
Yea, its definitely broken on F19. Been busy lately, but I'll check this today.
Comment 2 Jay Guerette 2013-09-13 15:33:23 EDT
I edited /usr/lib/python2.7/site-packages/autokey/gtkui/configwindow.py
I broke all the imports into individual lines. It errored on:
from gi.repository import GtkSource

I checked, and only gtksourceview2-2.11.2-15.fc19.x86_64 was installed.
So I installed gtksourceview3-3.8.2-1.fc19.x86_64.

autokey-gtk now starts properly.

The dependencies for this package should be updated.
Comment 3 Fedora Update System 2013-09-16 10:33:12 EDT
autokey-0.90.4-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/autokey-0.90.4-4.fc19
Comment 4 Fedora Update System 2013-09-16 20:25:25 EDT
Package autokey-0.90.4-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing autokey-0.90.4-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16887/autokey-0.90.4-4.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-09-24 18:52:45 EDT
autokey-0.90.4-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.