Bug 1008032 - oo-admin-clear-pending-ops fails to clear operations for SSH keys
oo-admin-clear-pending-ops fails to clear operations for SSH keys
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 16:55 EDT by Sten Turpin
Modified: 2015-05-14 20:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 12:51:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sten Turpin 2013-09-13 16:55:57 EDT
Description of problem: oo-admin-clear-pending-ops logging lots of add_ssh_key operations


Version-Release number of selected component (if applicable):
openshift-origin-broker-util-1.13.11-1.el6oso.noarch

How reproducible:
often, on STG and PROD

Steps to Reproduce:
1. run oo-admin-clear-pending-ops

Actual results:

Failed to clear op for user ([email redacted]) - #<PendingUserOps _id: 52168e82dbd93c7f28000206, _type: nil, created_at: 2013-08-22 22:19:46 UTC, updated_at: 2013-08-22 22:19:46 UTC, op_type: :add_ssh_key, state: "queued", arguments: {"_id"=>"52168e82dbd93c7f28000207", "type"=>"ssh-rsa", "name"=>"default", "content"=>"[ssh key redacted]", "_type"=>"UserSshKey"}, on_domain_ids: ["52168e472587c84b5c000382"], completed_domain_ids: [], on_completion_method: nil>

Expected results:


Additional info:
We're encountering dozens - hundreds of these messages when running clear-pending-ops, more log data is available
Comment 1 Abhishek Gupta 2013-09-16 18:19:59 EDT
The actual issue turned out to be that in PROD the add/remove ssh key user ops were not being cleared. This was due to a change made in the previous release that prevent user ops from being marked completed and deleted.

The fix has been made earlier in this sprint.
Comment 2 Jianwei Hou 2013-09-17 01:54:13 EDT
This is a bug caused by bug 1005631, which is fixed earlier this sprint.
Have verified on devenv-stage_475, the pending_ops can be cleared successfully.

[root@ip-10-238-145-84 ~]# oo-admin-clear-pending-ops -t 0
0 applications were cleaned up. 1 users were cleaned up. 0 domains were cleaned up.

Note You need to log in before you can comment on or make changes to this bug.