Bug 1008049 - SizeNotPositiveError: bytes= param must be >=0
SizeNotPositiveError: bytes= param must be >=0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
abrt_hash:4db36bd4f0b52e89778295e7bd3...
: Reopened
Depends On: 997690
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 20:07 EDT by Brian Lane
Modified: 2014-06-17 21:38 EDT (History)
17 users (show)

See Also:
Fixed In Version: anaconda-19.31.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 997690
Environment:
Last Closed: 2014-06-13 08:02:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2013-09-13 20:07:58 EDT
+++ This bug was initially created as a clone of Bug #997690 +++

Description of problem:
Start installer from rawhide boot.iso.
Click Installation Destination.
Click Done.

Version-Release number of selected component:
anaconda-20.6-1

The following was filed automatically by anaconda:
anaconda 20.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 136, in __new__
    raise SizeNotPositiveError("bytes= param must be >=0")
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 155, in __radd__
    return Size(bytes=Decimal.__radd__(self, other, context=context))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 177, in _get_sw_needs_text
    "total": required_space_text + auto_swap,
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 239, in refresh
    sw_text = self._get_sw_needs_text(required_space, auto_swap)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 848, in on_back_clicked
    self.encrypted)
SizeNotPositiveError: bytes= param must be >=0

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x20rawhide\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-0.rc5.git2.1.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        rawhide

--- Additional comment from Steve Tyler on 2013-08-15 22:54:21 EDT ---



--- Additional comment from Steve Tyler on 2013-08-15 22:54:26 EDT ---



--- Additional comment from Steve Tyler on 2013-08-15 22:54:30 EDT ---



--- Additional comment from Steve Tyler on 2013-08-15 22:54:34 EDT ---



--- Additional comment from Steve Tyler on 2013-08-15 22:54:39 EDT ---



--- Additional comment from Steve Tyler on 2013-08-15 22:54:43 EDT ---



--- Additional comment from Steve Tyler on 2013-08-15 22:54:48 EDT ---



--- Additional comment from Steve Tyler on 2013-08-15 22:54:52 EDT ---



--- Additional comment from Steve Tyler on 2013-08-15 22:54:58 EDT ---



--- Additional comment from Steve Tyler on 2013-08-15 22:55:03 EDT ---



--- Additional comment from Steve Tyler on 2013-08-15 22:55:08 EDT ---



--- Additional comment from Steve Tyler on 2013-08-15 23:24:10 EDT ---

Tested with:
$ qemu-kvm -m 4096 -hda f18-test-2.img -cdrom ~/xfr/fedora/rawhide/boot.iso -vga std -boot menu=on

The rawhide boot.iso does not have a version number, so these are a substitute:

$ file boot.iso
boot.iso: # ISO 9660 CD-ROM filesystem data 'Fedora rawhide x86_64           ' (bootable)

$ sha256sum boot.iso 
1e9b4df158d51dcdf8f245c1a0eba4aa190e044e7d296e5df3eacbcc05ebcbe7  boot.iso

$ isoinfo -lR -i boot.iso | egrep 'vmlinuz|squashfs'
-rwxr-xr-x   2    0    0         5653880 Aug 14 2013 [  31326 00]  vmlinuz 
-rw-r--r--   1    0    0       222838784 Aug 15 2013 [  49515 00]  squashfs.img 
-rwxr-xr-x   2    0    0         5653880 Aug 14 2013 [  31326 00]  vmlinuz 

$ file boot-loop/isolinux/vmlinuz 
boot-loop/isolinux/vmlinuz: Linux kernel x86 boot executable bzImage, version 3.11.0-0.rc5.git2.1.fc20.x86_64 (mockbuild@bkernel01.phx2.fedor, RO-rootFS, swap_dev 0x5, Normal VGA

--- Additional comment from Adam Williamson on 2013-08-17 03:14:04 EDT ---

Built a live image with today's Rawhide packages, booted it, went through gnome-initial-setup (which is a bug itself - #998083), then run 'sudo liveinst', completed language selection, and tried to do disk selection. Crash occurred at that point IIRC.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.utf8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=20130816-desktop-x86_64 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 slub_debug=- BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-0.rc5.git3.1.fc20.x86_64
other involved packages: python-blivet-0.19-1.fc20.noarch
package:        anaconda-20.6-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         SizeNotPositiveError: bytes= param must be >=0
release:        Fedora release 20 (Rawhide)
version:        rawhide

--- Additional comment from Adam Williamson on 2013-08-17 03:15:12 EDT ---

This appears to be a showstopper that's hit two people at least. Nominating as an Alpha blocker.

--- Additional comment from Christoph Frieben on 2013-08-17 06:14:04 EDT ---

Error occurred after confirming custom partititioning with ``DONE''.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.utf8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-20-Nightly-x86_64-Live-de rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-0.rc5.git3.1.fc20.x86_64
other involved packages: python-blivet-0.19-1.fc20.noarch
package:        anaconda-20.6-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         SizeNotPositiveError: bytes= param must be >=0
release:        Fedora release 20 (Rawhide)
version:        rawhide

--- Additional comment from David Lehman on 2013-08-19 12:09:50 EDT ---

It would be helpful if someone could apply this and test it.

--- Additional comment from Steve Tyler on 2013-08-19 13:45:21 EDT ---

With the patch applied, I get Installation Options, after clicking Done in Installation Destination, instead of a SizeNotPositiveError exception.

The next problem is that after clicking Custom Partitioning, I get an all-white screen instead of the Custom Partitioning dialog. There is no anaconda-tb-* file, however. This could be related to my choice of initial disk configuration ... will retest with a default, msdos-labeled disk configuration.

Tested with:
A pre-partitioned GPT disk image.

$ qemu-kvm -m 8192 -hda f19-test-3.img -cdrom ~/xfr/fedora/nightly-composes/Fedora-20-Nightly-x86_64-Live-desktop-20130816.11-1.iso -vga std -boot menu=on

--- Additional comment from Steve Tyler on 2013-08-19 14:52:09 EDT ---

Confirming that the patch fixes this bug.

Procedure:

$ qemu-img create f20-test-1.img 12G
Do a minimal F19 install with default storage configuration.

$ qemu-kvm -m 8192 -hda f20-test-1.img -cdrom ~/xfr/fedora/nightly-composes/Fedora-20-Nightly-x86_64-Live-desktop-20130816.11-1.iso -vga std -boot menu=on

Start patched anaconda-20.6-1 installer.

Click Installation Destination.
Installation Destination dialog is displayed.
Click Done.
The SizeNotPositiveError exception does not occur here.
Installation Options dialog is displayed.

What follows appears to be a different bug:

Click Cancel ...
Click Done.
Click Reclaim Space.
Reclaim Disk Space dialog is displayed.

Click Cancel.
Click Done.
Click Custom partitioning.

Installation Summary is unexpectedly displayed with all elements grayed.
The pointer is responsive, but no links respond to clicks, and no tooltips are displayed.
From a terminal, it can be seen that there is no anaconda-tb-* in /tmp.
Attaching to anaconda with strace shows the it is rapidly receiving repeated SIGSEGVs.

--- Additional comment from Steve Tyler on 2013-08-19 15:34:33 EDT ---

(In reply to Steve Tyler from comment #18)
...
> What follows appears to be a different bug:
...

Bug 998687 - SIGSEGV storm instead of Manual Partitioning

--- Additional comment from Kamil Páral on 2013-08-21 12:20:41 EDT ---

Discussed at 2013-08-21 blocker review meeting [1]. This is accepted as an Alpha blocker, because it violates the following F20 alpha release criterion: "The installer must be able to complete an installation to a single disk using automatic partitioning." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-08-21/
[2] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Disk_layouts

--- Additional comment from David Shea on 2013-08-26 14:48:21 EDT ---



--- Additional comment from Adam Williamson on 2013-08-29 21:29:14 EDT ---

I'm pretty sure this should be marked fixed at this point.

--- Additional comment from  on 2013-09-05 12:36:00 EDT ---

reported this bug in bugzilla from CD of netinstall Alpha TC-4  but do not see the entries.....fails at reclaim disk. (Bugzilla found this bug number)

--- Additional comment from Steve Tyler on 2013-09-05 12:46:29 EDT ---

(In reply to satellit from comment #23)
> reported this bug in bugzilla from CD of netinstall Alpha TC-4  but do not
> see the entries.....fails at reclaim disk. (Bugzilla found this bug number)

Thanks for your report. Reopening.

The bug was closed, so no comments for dupes are appended.
Could you attach /tmp/anaconda-tb, if possible?

--- Additional comment from Amit Saha on 2013-09-05 18:30:58 EDT ---

I was trying to reclaim space on my existing hard disk partition and when I did a "delete all", I ran into this crash.

Screencast link will be attached.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Scientific-KDE-x86_6 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
other involved packages: python-blivet-0.20-1.fc20.noarch
package:        anaconda-20.10-2.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         SizeNotPositiveError: spec= param must be >=0
release:        Fedora release 20 (Null)
version:        20

--- Additional comment from Amit Saha on 2013-09-05 18:53:26 EDT ---

(In reply to Amit Saha from comment #25)
> I was trying to reclaim space on my existing hard disk partition and when I
> did a "delete all", I ran into this crash.
> 
> Screencast link will be attached.

http://www.youtube.com/watch?v=isHmVG2sRzw

I was attempting to installed Fedora 20 TC4.

--- Additional comment from Jaroslav Reznik on 2013-09-07 04:45:00 EDT ---

Does reclaim fits Alpha criteria with automatic partitioning? Even as referenced, just rewriting existing data should be enough for Alpha.

--- Additional comment from David Lehman on 2013-09-09 11:50:05 EDT ---

Please, someone who is still seeing this crash, attach the /tmp/anaconda-tb-* file. It is impossible to fix this without it.

--- Additional comment from Tim Flink on 2013-09-09 16:27:55 EDT ---

I'm having a lot of trouble reproducing this. Following the video listed in c#26, I created a vm with a 70G disk and have been using the F20 alpha TC4 x64 KDE live.

Even following the steps shown in the video almost verbatim (down to deselecting and reselecting the install target disk), I can't get anything to crash - the install proceeds without issue. I'll do a few more installs but I'm sceptical that I'm going to get a repo here.

--- Additional comment from Amit Saha on 2013-09-09 20:07:13 EDT ---

This is the requested file with TC5 while attempting to delete all partitions

--- Additional comment from Petr Schindler on 2013-09-10 08:53:47 EDT ---

I can't reproduce it too. I followed the video from comment 26 but I had no luck. I tested it on bare metal and on virtual machine.

--- Additional comment from David Lehman on 2013-09-10 09:56:52 EDT ---

Given that most people cannot reproduce this, it may be that there is something specific to Amit's disk layout that is triggering the crash.

It may be worth noting that the crash is in signal handler code that's triggered when the user moves the resize slider. (Yes -- I realize that the resize slider does not even appear in the reproducer video.)

--- Additional comment from Tim Flink on 2013-09-11 15:44:15 EDT ---

started install with F20 alpha RC1 x86_64 DVD burned to a USB stick using livecd-iso-to-disk and booted with EFI.

I selected a disk, and standard partition autopart. After selecting "delete all" on the existing partitions, I got the crash after clicking on "reclaim space"

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/syslinux/vmlinuz inst.stage2=hd:UUID=5F18-9593 quiet
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.14-1
product:        Fedora
reason:         SizeNotPositiveError: spec= param must be >=0
release:        Cannot get release name.
version:        20-Alpha

--- Additional comment from Fedora Update System on 2013-09-11 21:02:30 EDT ---

anaconda-20.15-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.15-1.fc20

--- Additional comment from Tim Flink on 2013-09-12 06:37:34 EDT ---

I re-confirmed that I could reproduce this bug with F20 alpha RC1 (anaconda-20.14-1.fc20) before attempting an install with F20 alpha RC2 (anaconda-20.15-1.fc20).

Confirmed that the fix works, moving to VERIFIED
Comment 5 Jan Stodola 2014-04-10 05:27:29 EDT
Unable to reproduce original issue.
Retested several times with anaconda-19.31.75-1.el7, reclaiming disk space worked fine, tested with LVM, native (XFS/ext4), RAID and encrypted partitions.

Verified: SanityOnly
Comment 6 Ludek Smid 2014-06-13 08:02:53 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.