Bug 1008056 - genaliases on Postfix is inefficient and can cause bounces
genaliases on Postfix is inefficient and can cause bounces
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mailman (Show other bugs)
6.4
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Pavel Šimerda (pavlix)
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 22:56 EDT by Nic Waller
Modified: 2016-08-17 02:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-17 02:33:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 266408 None None None Never

  None (edit)
Description Nic Waller 2013-09-13 22:56:26 EDT
Description of problem:
[Copied verbatim from LaunchPad]
"While genaliases is running, incoming posts and admin mail to some lists can bounce, with "550 User unknown in virtual alias table". It appears that genaliases loops over all lists and calls MTA.create(mlist, nolock=True, quiet=quiet) for each list, which in turn calls _update_maps() which runs Postfix's postmap and postalias commands. Hence for a time while running genaliases the list of mappings loaded into Postfix is incomplete. The process can also take over a minute because of this repeated hashing."


Version-Release number of selected component (if applicable):
2.1.12-17.el6

This is already fixed in Mailman 2.1.15, but I am suggesting a backport of this fix to RHEL 6 because this bug can lead to unexpected downtime if run on production servers with a lot of mailing lists.


How reproducible:
Deterministic.


Steps to Reproduce:
1. Have many (1000+) mailing lists.
2. Execute /usr/lib/mailman/bin/genaliases


Actual results:
It takes a long time (minutes, or more) to rebuild the aliases file and causes problems with listserv delivery while it is running.


Expected results:
Genaliases should execute almost instantly (~1 second). If it must run longer, it should behave in such a way that mail delivery is not disrupted.


Additional info:
On my test machine I observe these runtimes:
100 lists = 2.9 seconds (34 lists/sec)
200 lists = 6.6 seconds (30 lists/sec)
300 lists = 10.4 seconds (28 lists/sec)
400 lists = 15.1 seconds (26 lists/sec)
500 lists = 20.8 seconds (24 lists/sec)
900 lists = 47.8 seconds (18 lists/sec)
1900 lists = 169.3 seconds (11 lists/sec)
2900 lists = 318.1 seconds (9 lists/sec)

This is made worse by having the aliases file on slow I/O. On my Mailman server the aliases file is on an NFS mount, and running genaliases with 300 lists still had not completed within 5 minutes.
Comment 1 Nic Waller 2013-09-13 22:59:31 EDT
I attempted to patch my installation as described in the linked issue from Mailman LaunchPad, but noticed that "bin/rmlist" no longer worked after applying the patch. So the exact patch that went into Mailman 2.1.15 might be different than what is shown on the linked ticket.
Comment 3 Jan Kaluža 2013-09-16 03:52:26 EDT
(In reply to Nic Waller from comment #1)
> I attempted to patch my installation as described in the linked issue from
> Mailman LaunchPad, but noticed that "bin/rmlist" no longer worked after
> applying the patch. So the exact patch that went into Mailman 2.1.15 might
> be different than what is shown on the linked ticket.

Can I understand it like this is what you later submitted to bugzilla as Bug 1008139 and it is not connected with the patch from launchpad?
Comment 4 Nic Waller 2013-09-18 17:21:31 EDT
(In reply to Jan Kaluža from comment #3)
> (In reply to Nic Waller from comment #1)
> > I attempted to patch my installation as described in the linked issue from
> > Mailman LaunchPad, but noticed that "bin/rmlist" no longer worked after
> > applying the patch. So the exact patch that went into Mailman 2.1.15 might
> > be different than what is shown on the linked ticket.
> 
> Can I understand it like this is what you later submitted to bugzilla as Bug
> 1008139 and it is not connected with the patch from launchpad?

That is correct - these two bugs are separate and unrelated.

The only reason that I submitted another bug around the same time, is because the second bug was revealed to me while I was testing workarounds for this genaliases bug.
Comment 5 RHEL Product and Program Management 2013-10-13 19:10:29 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 11 Pavel Šimerda (pavlix) 2016-07-20 09:13:03 EDT
The bug is still open upstream despite the reporter's claim that this is already fixed in 2.1.15. And so there's no upstream patch to be backported. Or is there any partuclar patch to didcuss?

https://sourceforge.net/p/mailman/bugs/1199/
Comment 12 Nic Waller 2016-07-29 19:29:48 EDT
I'm fine if you just close this issue as unresolved. I am no longer working with RedHat-based systems, and I am no longer administrating any Mailman mailing lists. There doesn't seem to be anybody else affected by this bug, so I don't think it's worth any further effort.
Comment 13 Nic Waller 2016-08-15 17:29:51 EDT
I'm replying again just to clear the needinfo flag on this ticket. I no longer have any interest in a resolution to this bug, so please remove me from the discussion.
Comment 14 Tomáš Hozza 2016-08-17 02:33:02 EDT
Red Hat Enterprise Linux version 6 is entering the Production 2 phase of its lifetime and this bug doesn't meet the criteria for it, i.e. only high severity issues will be fixed. Please see https://access.redhat.com/support/policy/updates/errata/ for further information.

This issue is being tracked upstream:
https://sourceforge.net/p/mailman/bugs/1199/

Note You need to log in before you can comment on or make changes to this bug.