Bug 1008068 - after updrade zarafa from 7.0.13 to 7.1.15 it no longer possible to send emails
Summary: after updrade zarafa from 7.0.13 to 7.1.15 it no longer possible to send emails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: zarafa
Version: 18
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-14 11:05 UTC by uwe
Modified: 2013-12-25 13:26 UTC (History)
9 users (show)

Fixed In Version: zarafa-7.1.7-1.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-16 22:56:02 UTC


Attachments (Terms of Use)

Description uwe 2013-09-14 11:05:08 UTC
Description of problem:
after updating zarafa from 7.0.13 to 7.1.15 an a fedora 18 machine it is no longer possible to send emails.
Getting email works but when I send emails via webacces, webapp or from mobile I get the following email back :

--unfortunately, I was unable to deliver your mail.
--The error given was:
--Conversion error: 0X80004005. No error details specified. Your email is not --sent at all and cannot be retried.
--You may need to contact your e-mail administrator to solve this problem.

I cannot find any reason in the logfiles as you can see :
spooler.log :
Fri Sep 13 18:42:42 2013: [ 2717] Sending e-mail for user uwe, subject: '', size: 1912
Fri Sep 13 18:42:42 2013: [ 2717] VMIME exception: No factory available.
Fri Sep 13 18:42:42 2013: [ 2717] Could not parse mail body
Fri Sep 13 18:42:42 2013: [ 2717] E-mail for user uwe could not be sent, notifying user

updated packages
Version Dep-Install  kyotocabinet-libs-1.2.76-3.fc18.x86_64 @updates
    Aktualisiert libmapi-7.0.13-1.fc18.x86_64           @updates
    Update               7.1.5-1.fc18.x86_64            @updates
    Aktualisiert php-mapi-7.0.13-1.fc18.x86_64          @updates
    Update                7.1.5-1.fc18.x86_64           @updates
    Aktualisiert python-MAPI-7.0.13-1.fc18.x86_64       @updates
    Update                   7.1.5-1.fc18.x86_64        @updates
    Aktualisiert zarafa-7.0.13-1.fc18.x86_64            @updates
    Update              7.1.5-1.fc18.x86_64             @updates
    Aktualisiert zarafa-client-7.0.13-1.fc18.x86_64     @updates
    Update                     7.1.5-1.fc18.x86_64      @updates
    Aktualisiert zarafa-common-7.0.13-1.fc18.noarch     @updates
    Update                     7.1.5-1.fc18.noarch      @updates
    Aktualisiert zarafa-contacts-7.0.13-1.fc18.x86_64   @updates
    Update                       7.1.5-1.fc18.x86_64    @updates
    Aktualisiert zarafa-dagent-7.0.13-1.fc18.x86_64     @updates
    Update                     7.1.5-1.fc18.x86_64      @updates
    Aktualisiert zarafa-gateway-7.0.13-1.fc18.x86_64    @updates
    Update                      7.1.5-1.fc18.x86_64     @updates
    Aktualisiert zarafa-ical-7.0.13-1.fc18.x86_64       @updates
    Update                   7.1.5-1.fc18.x86_64        @updates
    Veraltet     zarafa-indexer-7.0.13-1.fc18.x86_64    @updates
    Aktualisiert zarafa-monitor-7.0.13-1.fc18.x86_64    @updates
    Update                      7.1.5-1.fc18.x86_64     @updates
    Obsoleting   zarafa-search-7.1.5-1.fc18.x86_64      @updates
    Aktualisiert zarafa-server-7.0.13-1.fc18.x86_64     @updates
    Update                     7.1.5-1.fc18.x86_64      @updates
    Aktualisiert zarafa-spooler-7.0.13-1.fc18.x86_64    @updates
    Update                      7.1.5-1.fc18.x86_64     @updates
    Aktualisiert zarafa-utils-7.0.13-1.fc18.x86_64      @updates
    Update                    7.1.5-1.fc18.x86_64       @updates
    Aktualisiert zarafa-webaccess-7.0.13-1.fc18.noarch  @updates
    Update                        7.1.5-1.fc18.noarch   @updates
and also 
libvmime-0.9.2-0.4.20110626svn.fc18.x86_64                 @fedora
    Update                0.9.2-0.8.20130324git.fc18.x86_64


How reproducible:
updade zarafa packages from 7.0.13 to 7.1.5


Steps to Reproduce:
1. yum update zarafa*
2. yum update libvmime
3. change the server.cfg like in the description of the zarafa dokumentation

Actual results:
it's no longer possible to send emails
the rules in the mailbox do mot logner work

Additional info:
n.a.

Comment 1 uwe 2013-09-14 21:52:54 UTC
I updated to fedora 19 and the problem still exists.
There are other users in the zarafa forum witch have the same problem !

regards Uwe

Comment 2 Robert Scheck 2013-09-14 22:01:00 UTC
https://forums.zarafa.com/showthread.php?9683-can-not-send-after-update-to-7-1-5 
is what you are actually referring to. In theory the issue is caused somewhere by
http://pkgs.fedoraproject.org/cgit/zarafa.git/tree/zarafa-7.1.4-libvmime092.patch
which was required as the older libvmime version was no longer compiling with 
recent versions of GnuTLS that Fedora 19+ are shipping. Unfortunately the newer
libvmime broke with the old libvmime that Zarafa is depending on. As it seems the
suggested patch in GIT (link above) isn't perfect. Except for Fedora 18 users,
the issue remains with 7.0.x and 7.1.x the same...an unusable Zarafa (either by
dependencies or by this libvmime breakage). The libvmime upstream is already now
notified for a suggestion - other patch proposals are also welcome.

Comment 3 Joerg 2013-09-20 16:25:50 UTC
I have the same issue,  so my mail server is currently down.

Can you please advice a workaround ?

Is it possible to downgrade ?

I am on Fedora 18

greetings Joerg.

Comment 4 James Hill 2013-09-23 12:47:22 UTC
Same issue with me.  libvmime is broken, waiting for upstream patch to make it down to the end users.

use imap and smtp to get around the issue of not beaing able to send email.
Spooler uses libvmime and thats where sending issues are occurring within zarafa.

Using a third part email client and connecting via imap to read emails and sending directing via smtp, thus bypassing zarafa-spooler.

If you also decide to upgrade to f19, be advised that mariadb doesn't quite work with zarafa-server. You'll need to install mysql-community instead.

The libvmime issue is same in both f18 and f19.

Comment 5 Marco Costantino 2013-10-02 11:49:12 UTC
I tried the upgrade to Zarafa 7.1.5 on Fedora 18 only before I upgrade to Fedora 19.

Zarafa-spooler does not work. With plugins enabled I get the following:

Wed Oct  2 12:35:55 2013: [14139] Connection to Zarafa server succeeded
Wed Oct  2 12:36:18 2013: [14228]   Python type: (null)
Wed Oct  2 12:36:18 2013: [14228]   Python error: No module named MAPI

If I disable the plugins I instead get:

Wed Oct  2 12:45:36 2013: [16090] Sending e-mail for user mrc, subject: 'test', size: 1727
Wed Oct  2 12:45:36 2013: [16090] VMIME exception: No factory available.
Wed Oct  2 12:45:36 2013: [16090] Could not parse mail body
Wed Oct  2 12:45:36 2013: [16090] E-mail for user mrc could not be sent, notifying user

Comment 6 Marco Costantino 2013-11-06 12:42:55 UTC
I was wondering if there was any update regarding this.. I am basically stuck with Fedora 18 and previous version of Zarafa, as upgrading to Fedora 19 would most likely inherit this problem.

Comment 7 uwe 2013-12-02 19:45:25 UTC
it looks like that there is nobody take care of the problem :-(
Zarafa is degraded to a simple imap/pop3 server.

Comment 8 Fedora Update System 2013-12-08 17:16:42 UTC
libvmime-0.9.2-0.9.20120406git.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libvmime-0.9.2-0.9.20120406git.fc20

Comment 9 Fedora Update System 2013-12-08 17:17:31 UTC
libvmime-0.9.2-0.9.20120406git.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libvmime-0.9.2-0.9.20120406git.fc19

Comment 10 Fedora Update System 2013-12-08 17:18:01 UTC
libvmime-0.9.2-0.9.20120406git.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libvmime-0.9.2-0.9.20120406git.fc18

Comment 11 Fedora Update System 2013-12-08 17:19:41 UTC
libvmime-0.9.2-0.9.20120406git.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/libvmime-0.9.2-0.9.20120406git.el6

Comment 12 Fedora Update System 2013-12-08 17:20:17 UTC
libvmime-0.9.2-0.9.20120406git.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/libvmime-0.9.2-0.9.20120406git.el5

Comment 13 Fedora Update System 2013-12-08 17:22:24 UTC
zarafa-7.1.7-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/zarafa-7.1.7-1.fc20

Comment 14 Fedora Update System 2013-12-08 17:24:07 UTC
zarafa-7.1.7-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/zarafa-7.1.7-1.fc19

Comment 15 Fedora Update System 2013-12-08 17:24:32 UTC
zarafa-7.1.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/zarafa-7.1.7-1.fc18

Comment 16 Fedora Update System 2013-12-08 17:25:29 UTC
zarafa-7.1.7-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/zarafa-7.1.7-1.el6

Comment 17 Fedora Update System 2013-12-08 17:27:06 UTC
zarafa-7.1.7-1.el5,php53-mapi-7.1.7-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/zarafa-7.1.7-1.el5,php53-mapi-7.1.7-1.el5

Comment 18 Fedora Update System 2013-12-09 01:58:51 UTC
Package libvmime-0.9.2-0.9.20120406git.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvmime-0.9.2-0.9.20120406git.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22990/libvmime-0.9.2-0.9.20120406git.fc19
then log in and leave karma (feedback).

Comment 19 uwe 2013-12-10 16:52:57 UTC
Hi,
I tested it with libvmime-0.9.2-0.9.20120406git.fc19 and zarafa-7.1.7-1.fc19 from the testing repository and it solves my problems :-)
I can send emails from webacces, webapp and smartphone and also the email filter rule functionality works now.

best regards
Uwe

Comment 20 Robert Scheck 2013-12-10 22:12:18 UTC
Uwe, can you please add positive karma to both packages in Bodhi (see links
above)?

Comment 21 Robert Scheck 2013-12-10 22:12:49 UTC
Sorry, forget comment #20. You already gave feedback there. Great & thanks!

Comment 22 Fedora Update System 2013-12-16 22:56:02 UTC
libvmime-0.9.2-0.9.20120406git.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2013-12-16 22:56:13 UTC
zarafa-7.1.7-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2013-12-16 22:58:08 UTC
zarafa-7.1.7-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2013-12-16 23:01:29 UTC
libvmime-0.9.2-0.9.20120406git.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2013-12-17 19:08:53 UTC
libvmime-0.9.2-0.9.20120406git.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2013-12-17 19:14:49 UTC
zarafa-7.1.7-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 28 James Hill 2013-12-18 11:39:03 UTC
I can confirm with UWE, that this has indeed fixed the issues  :-)


---
Using: F19 x86_64

Comment 29 Fedora Update System 2013-12-24 17:55:38 UTC
libvmime-0.9.2-0.9.20120406git.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 30 Fedora Update System 2013-12-24 17:55:50 UTC
zarafa-7.1.7-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 31 Fedora Update System 2013-12-24 17:56:01 UTC
libvmime-0.9.2-0.9.20120406git.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 32 Fedora Update System 2013-12-24 17:56:35 UTC
zarafa-7.1.7-1.el5, php53-mapi-7.1.7-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 33 Marco Costantino 2013-12-25 13:26:36 UTC
all upgraded. Works perfectly.

Thanks a lot for all your help.


Note You need to log in before you can comment on or make changes to this bug.