This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1008086 - spacewalk-setup failed with Oracle 11g Database
spacewalk-setup failed with Oracle 11g Database
Status: CLOSED NOTABUG
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
2.0
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: space27
  Show dependency treegraph
 
Reported: 2013-09-14 10:37 EDT by SASIKUMAR K
Modified: 2017-09-28 14:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-08 11:15:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
I can not solve the bug manually!!! (2.18 KB, text/plain)
2013-09-14 10:37 EDT, SASIKUMAR K
no flags Details

  None (edit)
Description SASIKUMAR K 2013-09-14 10:37:39 EDT
Created attachment 797654 [details]
I can not solve the bug manually!!!

Description of problem: 
I followed the steps.,
https://fedorahosted.org/spacewalk/wiki/HowToInstall
                       &&
https://fedorahosted.org/spacewalk/wiki/OracleXeSetup

Version-Release number of selected component (if applicable): spacewalk 2.0, oracle 11g - oracle-xe-11.2.0-1.0.x86_64.rpm, oracle-instantclient11.2-basic-11.2.0.3.0-1.x86_64.rpm, oracle-instantclient11.2-sqlplus-11.2.0.3.0-1.x86_64.rpm


Actual results: 
Could not install database.

Expected results:
Successful execution of 
# spacewalk-setup --disconnected --answer-file=answers.txt

Additional info:

# tail /var/log/rhn/install_db.log
/usr/share/spacewalk/setup/oracle/install-db.sh: line 57: .: oraenv: file not found
Comment 1 Milan Zazrivec 2013-09-16 02:23:09 EDT
Did you specify the --external-db option when installing running
spacewalk-setup ?
Comment 2 Milan Zazrivec 2013-11-08 11:15:20 EST
I'm closing this bug report, since the error shown comes from a part
of spacewalk-setup, which tries to setup embedded Oracle DB -- this
never happens on Spacewalk, where users, for Oracle DB backend, are
supposed to use spacewalk-setup --external-db
Comment 3 SASIKUMAR K 2014-11-10 20:48:04 EST
I updated my RPMs,,,
Kindly close this.
Comment 4 Eric Herget 2017-09-28 14:06:14 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.