Bug 1008091 - Building with tycho seems to fail on arm builders
Building with tycho seems to fail on arm builders
Status: CLOSED DUPLICATE of bug 1008307
Product: Fedora
Classification: Fedora
Component: tycho (Show other bugs)
arm Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
Depends On: 1008307
Blocks: 992169
  Show dependency treegraph
Reported: 2013-09-14 12:07 EDT by Gerard Ryan
Modified: 2014-01-12 19:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-09-16 02:21:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gerard Ryan 2013-09-14 12:07:35 EDT
Description of problem:
I'm trying to build eclipse-jbosstools, but every time that an arm builder is chosen in koji, the build fails. I'm not sure exactly if the problem is with tycho, but it looks like it's tycho/maven related.

How reproducible:
It seems to be only on armv7hl. Also, I've only run into the problem on f20, since that's the only place I seem to have been given arm builders. Incredibly, on my 4 attempts, the two scratch builds have been done on x86, so then I go to do a real build, thinking everything is fine, and I get an arm one and it fails.



Here's the build.log from one of the failures (I think those get cleared after a week or so): http://galileo.fedorapeople.org/arm-build.log

Additional info:
I was talking to Dennis Gilmore on #fedora-devel about this, and he mentioned that if necessary, he can provide access to arm systems to test/debug on.
Comment 1 Krzysztof Daniel 2013-09-16 02:21:49 EDT
Hey Gerard,
see the bug 1008307 for workaround.

*** This bug has been marked as a duplicate of bug 1008307 ***

Note You need to log in before you can comment on or make changes to this bug.