Bug 1008101 - libpng spec should require autoconf 2.68 instead of 2.65 to match configure
libpng spec should require autoconf 2.68 instead of 2.65 to match configure
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libpng (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Petr Hracek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-14 13:56 EDT by Justin Dearing
Modified: 2013-09-25 08:53 EDT (History)
3 users (show)

See Also:
Fixed In Version: libpng-1.6.6-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-25 08:53:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Dearing 2013-09-14 13:56:47 EDT
I am building the libpng arpm from rawhide on a highly modified CentOS 6.4 box with autoconf 2.65. rpmbuild -ba fails because  autoconf is not >= 2.68. Therefore the line in the spec should read:

BuildRequires: autoconf >= 2.68

Full error message I get is below:

Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.K3Ireu
+ umask 022
+ cd /home/mono/rpmbuild/BUILD
+ cd libpng-1.6.3
+ autoreconf -vi
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal -I scripts
configure.ac:17: error: Autoconf version 2.68 or higher is required
configure.ac:17: the top level
autom4te: /usr/bin/m4 failed with exit status: 63
aclocal: /usr/bin/autom4te failed with exit status: 63
autoreconf: aclocal failed with exit status: 63
error: Bad exit status from /var/tmp/rpm-tmp.K3Ireu (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.K3Ireu (%build)
Comment 1 Petr Hracek 2013-09-25 08:53:00 EDT
After discussion with our autoconf expert row were changed to:
BuildRequires autoconf >= 2.68

But current version of autoconf in rawhide is 2.69.

scm-commit (https://lists.fedoraproject.org/pipermail/scm-commits/Week-of-Mon-20130923/1117727.html) -> CLOSED RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.