Bug 1008123 - Can't disable/enable Wi-Fi device ath9k
Can't disable/enable Wi-Fi device ath9k
Status: CLOSED DUPLICATE of bug 954070
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fedora-kernel-wireless-ath
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-14 20:02 EDT by nucleo
Modified: 2014-05-01 16:15 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-04 10:39:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2013-09-14 20:02:50 EDT
Description of problem:
NetworkManager can't disable Wi-Fi device (LED shows that Wi-Fi on).


Version-Release number of selected component (if applicable):
kernel-3.11.1-300.fc20

How reproducible:
Always.

Steps to Reproduce:
1. Try to disable Wi-Fi in network manager.
2.
3.

Actual results:
Network manager shows Wi-Fi disabled but Wi-Fi LED is on, so device is actually enabled.

Expected results:
Should be possible to disable and enable device.

Additional info:
02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Last kernel with working disable/enable Wif-Fi was 3.5.7.
If I disable Wi-Fi with kernel 3.5.7 and then boot with all later kernels including 3.11 NetworkManager can't enable Wi-Fi and shows that it was disabled by hardware switch.
Comment 1 nucleo 2013-09-16 15:39:44 EDT
When Wi-Fi device disabled (LED off) 'rfkill list' shows with 3.5.7 kernel:

# rfkill list
0: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes
1: asus-wlan: Wireless LAN
        Soft blocked: yes
        Hard blocked: no


with 3.11.1 kernel:

# rfkill list
0: asus-wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
Comment 2 Zoltán Magyar 2013-10-01 03:27:53 EDT
Probably related to bug 954070 ?
Cheers!
Comment 3 John Greene 2014-03-04 10:39:46 EST
(In reply to Zoltán Magyar from comment #2)
> Probably related to bug 954070 ?
> Cheers!

Yes, appears to be a duplicate of 954070

*** This bug has been marked as a duplicate of bug 954070 ***
Comment 4 John Greene 2014-05-01 16:12:36 EDT
Was this on Asus hardware?  Chasing a theory..
Comment 5 nucleo 2014-05-01 16:15:43 EDT
Yes, Asus EeePC X101CH.

Note You need to log in before you can comment on or make changes to this bug.