Bug 1008141 - invisible cursor in X with spice-vdagent
invisible cursor in X with spice-vdagent
Status: CLOSED DUPLICATE of bug 1008965
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-qxl (Show other bugs)
20
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Alon Levy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-15 03:55 EDT by Hajime Taira
Modified: 2014-08-04 18:10 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-12 04:13:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hajime Taira 2013-09-15 03:55:46 EDT
Description of problem:
I can't see cursor in X

Version-Release number of selected component (if applicable):
xorg-x11-drv-qxl-0.1.1-0.14.20130703git8b03ec16.fc20.x86_64
spice-vdagent-0.14.0-5.fc20.x86_64

How reproducible:
I connected to f20 guest via f19 virt-manager or remote-viewer when installed following package.
spice-vdagent-0.14.0-5.fc20.x86_64

Actual results:
invisible cursor in X


Expected results:
visible cursor in X

Additional info:
spice client environment are
virt-manager-0.10.0-1.fc19.noarch
virt-viewer-0.5.6-1.fc19.x86_64
Comment 1 Hans de Goede 2013-09-15 05:25:56 EDT
The agent does not draw the cursor, most likely this is an issue with the new kms code, changing component to xorg-x11-drv-qxl.
Comment 2 Cole Robinson 2013-09-18 11:08:30 EDT
Please provide /var/log/libvirt/qemu/$vmname.log so we can see the qemu command line
Comment 3 Hajime Taira 2013-09-18 22:00:28 EDT
qemu command line is following.

LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin QEMU_AUDIO_DRV=s
pice /usr/bin/qemu-kvm -name fedora20 -S -machine pc-i440fx-1.4,accel=kvm,usb=of
f -cpu SandyBridge,+osxsave,+pcid,+pdcm,+xtpr,+tm2,+est,+smx,+vmx,+ds_cpl,+monit
or,+dtes64,+pbe,+tm,+ht,+ss,+acpi,+ds,+vme -m 2048 -smp 2,sockets=2,cores=1,thre
ads=1 -uuid 1e6dc546-f036-e141-34b7-ed4effbeff23 -no-user-config -nodefaults -ch
ardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/fedora20.monitor,server,n
owait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdow
n -boot menu=off -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device vi
rtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x6 -device virtio-serial-pci,id=virtio-se
rial0,bus=pci.0,addr=0x5 -drive if=none,id=drive-ide0-1-0,readonly=on,format=raw
,cache=writethrough -device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0
-1-0 -drive file=/var/lib/libvirt/images/fedora20.img,if=none,id=drive-scsi0-0-0
-0,format=qcow2,cache=writethrough -device scsi-hd,bus=scsi0.0,channel=0,scsi-id
=0,lun=0,drive=drive-scsi0-0-0-0,id=scsi0-0-0-0,bootindex=1 -netdev tap,fd=26,id
=hostnet0,vhost=on,vhostfd=27 -device virtio-net-pci,netdev=hostnet0,id=net0,mac
=52:54:00:f9:71:55,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-se
rial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdage
nt -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=chan
nel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -spice port=5902,addr=
0.0.0.0,disable-ticketing,seamless-migration=on -vga qxl -global qxl-vga.ram_siz
e=67108864 -global qxl-vga.vram_size=67108864 -device AC97,id=sound0,bus=pci.0,a
ddr=0x4 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7
Comment 4 Grega Bremec 2013-12-08 07:34:31 EST
I have the exact same result. Fedora 20 beta running on Fedora 19 host.

Both virt-viewer and vinagre yield the same thing.

spice-glib-0.20-6.fc19.x86_64
spice-gtk-0.20-6.fc19.x86_64
spice-gtk3-0.20-6.fc19.x86_64
spice-gtk-tools-0.20-6.fc19.x86_64
spice-vdagent-0.14.0-5.fc19.x86_64
vinagre-3.8.2-1.fc19.x86_64
virt-viewer-0.5.6-1.fc19.x86_64

qemu command line (disk, network and other irrelevant options removed):

/usr/bin/qemu-system-x86_64 -machine accel=kvm -name f20beta -S -machine pc-i440fx-1.4,accel=kvm,usb=off ... -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/f20beta.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control ... -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -device usb-mouse,id=input1 -spice port=5900,addr=127.0.0.1,disable-ticketing,seamless-migration=on -vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=67108864 ...
Comment 5 Alon Levy 2013-12-08 09:40:03 EST
(In reply to Grega Bremec from comment #4)
> I have the exact same result. Fedora 20 beta running on Fedora 19 host.
> 
> Both virt-viewer and vinagre yield the same thing.
> 
> spice-glib-0.20-6.fc19.x86_64
> spice-gtk-0.20-6.fc19.x86_64
> spice-gtk3-0.20-6.fc19.x86_64

Please upgrade to spice-gtk-0.20-7 and spice-gtk3-0.20-7

https://koji.fedoraproject.org/koji/buildinfo?buildID=472680

And report if it fixes your problem, thanks.

> spice-gtk-tools-0.20-6.fc19.x86_64
> spice-vdagent-0.14.0-5.fc19.x86_64
> vinagre-3.8.2-1.fc19.x86_64
> virt-viewer-0.5.6-1.fc19.x86_64
> 
> qemu command line (disk, network and other irrelevant options removed):
> 
> /usr/bin/qemu-system-x86_64 -machine accel=kvm -name f20beta -S -machine
> pc-i440fx-1.4,accel=kvm,usb=off ... -chardev
> socket,id=charmonitor,path=/var/lib/libvirt/qemu/f20beta.monitor,server,
> nowait -mon chardev=charmonitor,id=monitor,mode=control ... -chardev
> pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0
> -chardev spicevmc,id=charchannel0,name=vdagent -device
> virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,
> name=com.redhat.spice.0 -device usb-tablet,id=input0 -device
> usb-mouse,id=input1 -spice
> port=5900,addr=127.0.0.1,disable-ticketing,seamless-migration=on -vga qxl
> -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=67108864 ...
Comment 6 Grega Bremec 2013-12-09 11:48:13 EST
(In reply to Alon Levy from comment #5)
> (In reply to Grega Bremec from comment #4)
> > I have the exact same result. Fedora 20 beta running on Fedora 19 host.
> > 
> > Both virt-viewer and vinagre yield the same thing.
> > 
> > spice-glib-0.20-6.fc19.x86_64
> > spice-gtk-0.20-6.fc19.x86_64
> > spice-gtk3-0.20-6.fc19.x86_64
> 
> Please upgrade to spice-gtk-0.20-7 and spice-gtk3-0.20-7

Hm. I sent an e-mail reply, but for some reason, it doesn't make it to this summary page. Weird.

Repeating it here in the hopes my e-mail went to /dev/null. Ignore it if it arrives later.

Actually, upgrading the *guest* seems to have fixed it. o_O

I will retry a couple of times and compare to a fresh (re)installation, but for now, I have quite consistent results (4/5 times with cursor) by upgrading the following:

    xorg-x11-drv-qxl-0.1.1-0.14.20130703git8b03ec16.fc20.x86_64
    spice-glib-0.20-5.fc20.x86_64
    spice-gtk3-0.20-5.fc20.x86_64
    spice-server-0.12.4-2.fc20.x86_64
    spice-vdagent-0.14.0-5.fc20.x86_64

to these:

    xorg-x11-drv-qxl-0.1.1-3.fc20.x86_64
    spice-glib-0.21-5.fc20.x86_64
    spice-gtk3-0.21-5.fc20.x86_64
    spice-server-0.12.4-3.fc20.x86_64
    spice-vdagent-0.15.0-1.fc20.x86_64

After I either confirm or reject this idea, I will definitely try with host upgrade as well.

Thanks for your input, Alon.
Comment 7 Grega Bremec 2013-12-11 15:27:37 EST
After looking around a bit, I found this to be a duplicate of 1008965.

The updates I mentioned above were part of the massive "update all" operation I did after installing F20 beta for the first time.

Updating gnome-desktop3-3.10.1-1.fc20 to gnome-desktop3-3.10.2-2.fc20 in the guest is the package that fixed the problem.
Comment 8 Alon Levy 2013-12-12 02:58:00 EST
Hajime, can you confirm comment 7? If so we can close this as a duplicate,

Thanks,
Alon
Comment 9 Hajime Taira 2013-12-12 03:13:57 EST
I'm using gnome-desktop3-3.10.1-1.fc20. I confirmed fixed the problem on 3.10.1-1.fc20.
Comment 10 Alon Levy 2013-12-12 04:13:15 EST
Closing as duplicate per comment 7 and comment 9

*** This bug has been marked as a duplicate of bug 1008965 ***

Note You need to log in before you can comment on or make changes to this bug.