Bug 1008185 - ACPICA Tools Update
ACPICA Tools Update
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pete Travis
Fedora Docs QA
: Tracking
Depends On: 998504 1008186
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-15 13:11 EDT by Pete Travis
Modified: 2014-01-13 15:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 998504
Environment:
Last Closed: 2014-01-13 08:56:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Travis 2013-09-15 13:11:14 EDT
+++ This bug was initially created as a clone of Bug #998504 +++

This is a tracking bug for Change: ACPICA Tools Update
For more details, see: http://fedoraproject.org//wiki/Changes/AcpicaTools

For developers working with the ACPI subsystem, there are tools available from the reference implementation at http://www.acpica.org.  These tools have been restructured over time and the current Fedora packages as a result contain either outdated versions or do not make available a complete set of tools.  We propose an acpica-tools package that replaces both the existing iasl package and the the existing pmtools package in order to make all current tools available, and make it more straightforward in the future to keep them up-to-date.

--- Additional comment from Al Stone on 2013-08-28 18:08:23 EDT ---

Package has been uploaded into git and builds done for all architectures for f20.

--- Additional comment from John Freed on 2013-09-09 04:02:26 EDT ---

acpica-tools obsoletes pmtools, but it appears it should also obsolete iasl:


Transaction check error:
  file /usr/bin/iasl from install of acpica-tools-20130823-2.fc19.x86_64 conflicts with file from package iasl-20120913-7.fc19.x86_64
  file /usr/share/man/man1/iasl.1.gz from install of acpica-tools-20130823-2.fc19.x86_64 conflicts with file from package iasl-20120913-7.fc19.x86_64


Erasing iasl and installing acpica-tools works.
Comment 1 Pete Travis 2013-09-15 13:57:15 EDT
Change details at https://fedoraproject.org/wiki/Changes/AcpicaTools

Discussion at https://lists.fedoraproject.org/pipermail/devel-announce/2013-July/001202.html

Please document this Change in the release notes.
Comment 3 Al Stone 2013-10-19 15:17:45 EDT
(In reply to Pete Travis from comment #2)
> draft at
> https://git.fedorahosted.org/cgit/docs/release-notes.git/commit/
> ?id=343e3fc54f620240b5a0ef4fa9fe1e4c25b21d8f

Thanks, Pete.  The changes look fine to me.

Note You need to log in before you can comment on or make changes to this bug.