Bug 10082 - Burning Redhat 6.2 beta CD fails
Burning Redhat 6.2 beta CD fails
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
http://www.freelabs.com/~whitis/linux...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-09 01:41 EST by whitis
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-21 15:28:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description whitis 2000-03-09 01:41:45 EST
Due to permission problems which commonly acompany downloading, burning
a CD-ROM fails to produce a working copy.  The "Burning a RedHat CD
mini-HOWTO" gives a script to fix this but it does not work with 6.2
since the installer is now in python.  The "file" command on redhat 5.1
does not recognize python scripts, either.  Modifying the script
to make all .py files executable does not work.  I ended up burning
4 CD's before one would work.

Redhat should have included a script to fix permissions.

However, I have written a program which will fix the permissions
on every file when downloaded.  You may reference the URL in
your README file or included it in the download area and CD-ROMs.
It parses the "ls -lR" file and sets the permissions on every file
based on that.

Also, note that there does not seem to be a script/makefile to
make a distribution boot floppy.  This makes it difficult to
fix bugs or add enhancements to the installer.  In the past,
I have tried to dismantle the boot floppy, modify it, and put
it together but it failed for obscure layes.
Comment 1 Jay Turner 2000-03-21 15:28:59 EST
If a user is going to download the distribution for the purposes of making a
CDROM from it, then we recommend they download the .iso image, which will
preserve the permissions and all and get around these problems.

I will pass on the script for fixing permissions to the install developers here
at the office.

Note You need to log in before you can comment on or make changes to this bug.