This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1008236 - cgrlog 1.6.0-2 stripped too early during build
cgrlog 1.6.0-2 stripped too early during build
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cqrlog (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eric Christensen
Fedora Extras Quality Assurance
: Patch, Regression
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2013-09-15 16:03 EDT by Ville Skyttä
Modified: 2014-01-24 21:27 EST (History)
1 user (show)

See Also:
Fixed In Version: cqrlog-1.6.1-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-25 04:37:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2013-09-15 16:03:35 EDT
cgrlog 1.6.0-2 strips the executable too early during build, resulting in useless debuginfo package. One way to fix it:

--- a/cqrlog.spec
+++ b/cqrlog.spec
@@ -49,3 +49,3 @@ chmod -x voice_keyer/README
 %build
-make %{?_smp_mflags}
+make %{?_smp_mflags} ST=:
Comment 1 Ville Skyttä 2013-12-25 04:37:50 EST
No feedback and not fixed despite of new package release done since initial report, so done in Rawhide.
Comment 2 Eric Christensen 2014-01-13 19:20:51 EST
Good grief, I'm not sure how this bug didn't get my attention but it wasn't on my radar.  Thanks for fixing the problem.  I'm guessing I could do the same for all released versions as well?
Comment 3 Ville Skyttä 2014-01-14 03:50:51 EST
Sure, if you feel like this fix alone warrants pushing updates.
Comment 4 Fedora Update System 2014-01-14 15:38:08 EST
cqrlog-1.6.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cqrlog-1.6.1-2.fc19
Comment 5 Fedora Update System 2014-01-14 15:38:17 EST
cqrlog-1.6.1-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/cqrlog-1.6.1-2.fc20
Comment 6 Fedora Update System 2014-01-14 15:38:25 EST
cqrlog-1.6.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/cqrlog-1.6.1-2.fc18
Comment 7 Fedora Update System 2014-01-24 21:19:38 EST
cqrlog-1.6.1-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2014-01-24 21:27:42 EST
cqrlog-1.6.1-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.