Bug 10083 - Problems getting Deskjet 710c running.
Summary: Problems getting Deskjet 710c running.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lpr   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-09 06:50 UTC by ian hagan
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-09 07:03:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ian hagan 2000-03-09 06:50:00 UTC
Hello,
      I have a HP Deskjet 710c which I'm trying to get running on Linux
6.1. The printer works on Win95.

Printtool detects my lp port when I add the printer. Lpd starts without any
messages (other then lpd started). I also noticed that in messages the
parport polls the printer an DESKJET 710C appears, I assuming this has come
from the printer as I haven't told it.

When I submit jobs using lpr or tests with printtool the job appears on the
queue (lpq) then disapears. If I cat /etc/printcap > /dev/lp0  nothing
happens. No messages appear in /var/log/messages during this.

crw-rw----   1 root     daemon     6,   0 May  6  1998 /dev/lp0

I checked modprobe and there is a entry for lp ( alias char-major-6 lp )
lp also exists in the /proc/ioports (0278-027a : parport0    )

Comment 1 Bernhard Rosenkraenzer 2000-03-09 07:03:59 UTC
The HP Deskjet 710C is a WinPrinter, meaning it uses proprietary protocols
instead of standards; therefore it is not supported by ghostscript.

There is a tool called pbm2ppa (which we aren't shipping yet because it isn't
stable enough) that supports at least some basic functionality on WinPrinters
(check freshmeat.net or ftpsearch.lycos.com for pbm2ppa); this may help you.


Note You need to log in before you can comment on or make changes to this bug.