Bug 1008318 - [RHSC] Error message seen on starting rebalance on a volume with one brick needs improvement
[RHSC] Error message seen on starting rebalance on a volume with one brick ne...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity unspecified
: ---
: RHGS 2.1.2
Assigned To: Shubhendu Tripathi
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 03:00 EDT by Shruti Sampat
Modified: 2015-05-13 12:29 EDT (History)
9 users (show)

See Also:
Fixed In Version: cb3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:38:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19570 None None None Never

  None (edit)
Description Shruti Sampat 2013-09-16 03:00:59 EDT
Description of problem:
------------------------
On trying to start rebalance on a volume with a single brick, the error message appearing on the Console looks like this -

Error while executing action: Cannot rebalance Gluster Volume. Gluster Volume bricks are not distributed.

This message is not clear enough to the user, the message should say that rebalance cannot be started because the volume has a single brick.

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.4.0-0.2.master.20130911113322.gite7ade4a.fc19 

How reproducible:
Always

Steps to Reproduce:
1. Install oVirt in gluster-only mode.
2. Create a 3.3 cluster, add storage nodes and create a distributed volume with a single brick and start the volume.
3. Select the volume and click on Rebalance -> Start

Actual results:
The above described error message is seen as a pop-up.

Expected results:
Message should be more clear about the reason for start rebalance failure.

Additional info:
The same operation from gluster CLI results in the following -

[root@localhost ~]# gluster v rebalance dis_vol_1 start
volume rebalance: dis_vol_1: failed: Volume dis_vol_1 is not a distribute volume or contains only 1 brick.
Not performing rebalance
Comment 1 Shruti Sampat 2013-09-16 03:20:14 EDT
Hi Dusmant,

The same error message is seen on trying to start rebalance on volumes of types replicate and striped (on which rebalance cannot be done). This needs to be corrected as well. Let me know if you need a separate BZ for this.
Comment 3 Dusmant 2013-09-18 06:03:29 EDT
(In reply to Shruti Sampat from comment #1)
> Hi Dusmant,
> 
> The same error message is seen on trying to start rebalance on volumes of
> types replicate and striped (on which rebalance cannot be done). This needs
> to be corrected as well. Let me know if you need a separate BZ for this.

Lets use this bug for fixing those cases also, because they are kind of related.
Comment 4 Scott Haines 2013-09-23 19:34:57 EDT
Targeting for 2.1.z U2 (Corbett) release.
Comment 5 Shruti Sampat 2013-10-18 08:57:20 EDT
Verified as fixed in Red Hat Storage Console Version: 2.1.2-0.0.scratch.beta1.el6_4. 

The error message now says that the gluster volume has a single brick. For volume types other than distributed, the error message on trying to start rebalance says that the volume is not distributed.
Comment 7 errata-xmlrpc 2014-02-25 02:38:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.