Bug 1008323 - Kernel 3.11.1 panic
Kernel 3.11.1 panic
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Josh Boyer
Fedora Extras Quality Assurance
:
: 1011632 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 03:15 EDT by Vasiliy Glazov
Modified: 2013-10-02 02:35 EDT (History)
16 users (show)

See Also:
Fixed In Version: kernel-3.11.2-301.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 21:57:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel panic screenshot. (1.14 MB, image/jpeg)
2013-09-16 03:15 EDT, Vasiliy Glazov
no flags Details

  None (edit)
Description Vasiliy Glazov 2013-09-16 03:15:38 EDT
Created attachment 798131 [details]
Kernel panic screenshot.

Description of problem:
Kernel 3.11.1 from koji panic after about ten seconds of boot.

Version-Release number of selected component (if applicable):
kernel-3.11.1-200.fc19.x86_64

How reproducible:
Always.

Additional info:
Kernel 3.10.11 and early work normal.
Processor Intel Pentium 4.

Panic photo is attached.
Comment 1 Michele Baldessari 2013-09-16 07:24:10 EDT
Hi Vasiliy,

thanks for the report. The following changes took place in that driver from 3.10 to 3.11:
* e47851f - (2013-08-13 15:09:06 -0700)  skge: dma_sync the whole receive buffer <stephen hemminger>
* f7b7a36 - (2013-08-04 23:36:45 -0700)  skge: fix build on 32 bit <Stephen Hemminger>
* 136d8f3 - (2013-08-04 18:35:01 -0700)  skge: add dma_mapping check <stephen hemminger>
* 351638e - (2013-05-28 13:11:01 -0700)  net: pass info struct via netdevice notifier <Jiri Pirko>


So one of these is the culprit. Two questions:
- Are you able to reproduce this 100% of the time?
- Would you be able to bisect which of the four commits (136d8f3 and e47851f are the most likely ones) introduced this issue or do you need help with that?

Thanks and regards,
Michele
Comment 2 Vasiliy Glazov 2013-09-16 07:36:24 EDT
I can reproduce it 100% of the time.
And I need help with build kernel without this commits.

Can you give me four kernel-3.11.1 rpm packages with disabled one of commits?
Comment 3 Igor Gnatenko 2013-09-16 10:01:41 EDT
Michele, thanks for the info!
I prepare builds for testing.
Vasiliy, please test builds from here: http://ignatenkobrain.asuscomm.com:8080/kernel/ and inform us about tests.
Take this bug until find bad commit more accurately.
Comment 4 Vasiliy Glazov 2013-09-17 01:59:50 EDT
I checked kernels.
Panic not occur only on 351638e. On other kernel goes to panic with same backtrace.
Comment 5 Michele Baldessari 2013-09-18 04:37:59 EDT
Hi Vasiliy,

thanks a lot for testing. So * 136d8f3 - (2013-08-04 18:35:01 -0700)  skge: add dma_mapping check <stephen hemminger> is the regression commit.

Igor, do you want to take this to netdev or want me to do it?

regards,
Michele
Comment 6 Igor Gnatenko 2013-09-18 04:44:45 EDT
(In reply to Michele Baldessari from comment #5)
> Hi Vasiliy,
> 
> thanks a lot for testing. So * 136d8f3 - (2013-08-04 18:35:01 -0700)  skge:
> add dma_mapping check <stephen hemminger> is the regression commit.
> 
> Igor, do you want to take this to netdev or want me to do it?
> 
> regards,
> Michele
please do tihs.
Comment 7 Igor Gnatenko 2013-09-18 05:04:59 EDT
found this bug at KBZ
Comment 8 Josh Boyer 2013-09-18 16:30:26 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 9 Vasiliy Glazov 2013-09-19 01:41:23 EDT
Josh, this issue present exactly in 3.11.1-200.fc19
Comment 10 Igor Gnatenko 2013-09-19 03:32:51 EDT
Started discussion at maillists: https://lkml.org/lkml/2013/9/18/64
Comment 12 Igor Gnatenko 2013-09-19 14:24:18 EDT
Hi Josh,

Please apply as downstream patch from Mikulas.

http://permalink.gmane.org/gmane.linux.network/284140
Comment 13 Josh Boyer 2013-09-20 10:37:22 EDT
Applied.  Thank you for driving this forward.
Comment 14 Igor Gnatenko 2013-09-20 11:23:46 EDT
Josh, in the future we should apply http://permalink.gmane.org/gmane.linux.network/284249 like this patch.. but I think not needed rush..
Comment 15 Igor Gnatenko 2013-09-20 14:36:39 EDT
second part of patch from Mikulas http://permalink.gmane.org/gmane.linux.network/284277 but its not signed by netdevs
Comment 16 amreg 2013-09-21 13:45:20 EDT
The original description was about the 64-bit version of kernel-3.11.1-200.
Needless to say, this applies also to the 32-bit version.

The crash occurs about 10-15 seconds after boot ends: you have the time to log in, and to start an application (browser, mailer, ....), and then you got what the picture attached to the original description shows.

Additional question : the boot menu presents the last three installed versions of the kernel, with the last one as the default. Can this buggy 3.11.1 kernel version be uninstalled while keeping the 2 others (just for the sake of getting rid of the burden of manually selecting a healthy 3.10 version at boot time) ?
Comment 17 Krzysztof Mazurek 2013-09-21 15:25:02 EDT
This is also my case - wainting for patch working on kernel-3.10.11.
Comment 18 Vasiliy Glazov 2013-09-23 03:08:01 EDT
amreg, you can remove 3.11.1 kernel by command
yum remove "kernel-3.11.1*"
Comment 20 Josh Boyer 2013-09-25 10:19:15 EDT
Added the second patch as well.  Thanks.
Comment 21 Igor Gnatenko 2013-09-25 11:09:11 EDT
*** Bug 1011632 has been marked as a duplicate of this bug. ***
Comment 22 Fedora Update System 2013-09-27 17:42:21 EDT
kernel-3.11.2-201.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.11.2-201.fc19
Comment 23 mx 2013-09-28 11:35:14 EDT
I test kernel:
uname -r
3.11.2-201.fc19.x86_64

Net up! All good works ! Thanks.
Comment 24 Fedora Update System 2013-09-28 21:21:40 EDT
Package kernel-3.11.2-201.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.11.2-201.fc19'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17865/kernel-3.11.2-201.fc19
then log in and leave karma (feedback).
Comment 25 Vasiliy Glazov 2013-09-30 07:48:32 EDT
Bug solved in this update.
Comment 26 Rostislav Krasny 2013-09-30 07:53:52 EDT
When (In reply to Vasiliy Glazov from comment #25)
> Bug solved in this update.

When this update will be released?
Comment 27 Vasiliy Glazov 2013-09-30 07:57:33 EDT
Rostislav, you can install and use it now from koji. But this kernel may not be in updates at all because have some other problems.
Comment 28 Rostislav Krasny 2013-09-30 08:09:51 EDT
Vasiliy, if I install Fedora 19 it updates all packages, including the kernel, automatically. Then I have Fedora 19 with the 3.11.1 kernel and without any network because of the skge regression. At least it doesn't panic on my hardware configuration. Is it possible to downgrade the kernel to a previous (3.10.11 ?) version after the installation? I mean, does Fedora installer save previous (or at least original) versions or it installs the latest rpm's straight away?
Comment 29 Vasiliy Glazov 2013-09-30 08:15:21 EDT
When Fedora update kernel it leave three last installed kernels. So you choose previous kernel in Grub menu, load and manually update kernel to 3.11.2.
Comment 30 Fedora Update System 2013-09-30 12:27:58 EDT
kernel-3.11.2-301.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.11.2-301.fc20
Comment 31 amreg 2013-09-30 16:00:08 EDT
(In reply to Vasiliy Glazov from comment #18)
> amreg, you can remove 3.11.1 kernel by command
> yum remove "kernel-3.11.1*"

Thanks for the hint. In my case, it should rather be:
> yum remove "kernel-PAE-3.11.1*"
(I don't know why, but my box uses PAE fashions of the kernel).
I hope the patch would make its way in the PAE releases as well as in the "normal (?)" releases?
Basically, just mentioning the exact "base" kernel package name in yum (i.e. kernel-PAE-3.11.1-200.fc19") should release as well dependant packages for the same version (such as headers, doc, ...)?
Comment 32 Fedora Update System 2013-09-30 21:57:02 EDT
kernel-3.11.2-201.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 33 Fedora Update System 2013-10-02 02:35:57 EDT
kernel-3.11.2-301.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.