Bug 1008337 - Patching module does not work with IBM JDK 6
Patching module does not work with IBM JDK 6
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Patching (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: ER7
: EAP 6.2.0
Assigned To: Jan Martiska
Jan Martiska
Russell Dickenson
:
Depends On: 1006876
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 04:05 EDT by Jan Martiska
Modified: 2013-12-15 11:20 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:20:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Martiska 2013-09-16 04:05:28 EDT
Try compiling EAP with IBM JDK 1.6. It will fail with:

[ERROR] /home/jmartisk/Workspace/jboss-eap/patching/src/main/java/org/jboss/as/patching/metadata/PatchXml.java:[57,76] cannot find symbol
symbol  : method newFactory()
location: class javax.xml.stream.XMLOutputFactory
[ERROR] /home/jmartisk/Workspace/jboss-eap/patching/src/main/java/org/jboss/as/patching/generator/DistributionXml.java:[54,76] cannot find symbol
symbol  : method newFactory()
location: class javax.xml.stream.XMLOutputFactory

I think this error will cause runtime issues as well (if EAP is compiled with another JDK and then run on IBM 6), because it will appear when the classes PatchXml/DistributionXml are loaded so they can be used for parsing patch XML. However, I am unable to verify this hypothesis, because in 6.2.0.ER1, bug #1006876 prevents from applying patches on IBM JDK 6 whatsoever (the same error as described therein appears when trying to apply a patch). 

Proposed fix by pjelinek:
Instead of XMLOutputFactory.newFactory(), call XMLOutputFactory.newInstance()
Comment 1 Jan Martiska 2013-09-16 04:52:43 EDT
I don't think a fix is necessary in upstream, because WildFly 8 requires JDK 7.
Comment 3 Jan Martiska 2013-09-27 05:04:29 EDT
Fixed in 6.2.0.ER3.
Comment 7 Jan Martiska 2013-10-23 09:36:57 EDT
The exact same issue returned in ER6.

[ERROR] /home/jmartisk/Workspace/jboss-eap/patching/src/main/java/org/jboss/as/patching/metadata/PatchBundleXml.java:[49,76] cannot find symbol
[ERROR] symbol  : method newFactory()
[ERROR] location: class javax.xml.stream.XMLOutputFactory

Reopening the issue rather than creating a new one to save some time (this bug already has all the acks...)
Comment 9 Jan Martiska 2013-11-05 04:26:29 EST
Fixed in ER7.

Note You need to log in before you can comment on or make changes to this bug.