Bug 1008339 - kvm crashes with "KVM internal error" when running netware 5 as guest
kvm crashes with "KVM internal error" when running netware 5 as guest
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 04:16 EDT by Armands Liepins
Modified: 2013-11-20 14:29 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 14:29:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armands Liepins 2013-09-16 04:16:51 EDT
Description of problem:
KVM crashes when running netware 5 as guest:

KVM internal error. Suberror: 1
emulation failure
EAX=00000001 EBX=00000003 ECX=00006a60 EDX=00000008
ESI=00000008 EDI=000003be EBP=00000444 ESP=00000912
EIP=000044ca EFL=00000203 [------C] CPL=0 II=0 A20=1 SMM=0 HLT=0
ES =0116 00001160 0000ffff 00009300
CS =0019 00000190 0000ffff 00009b00
SS =0116 00001160 0000ffff 00009300
DS =4386 00043860 0000ffff 00009300
FS =0000 00000000 00ffffff 00c09300
GS =0000 00000000 00ffffff 00c09300
LDT=0000 00000000 0000ffff 00008200
TR =0000 00000000 0000ffff 00008b00
GDT=     00048090 0000028f
IDT=     00000000 000003ff
CR0=00000010 CR2=00000000 CR3=00000000 CR4=00000000
DR0=0000000000000000 DR1=0000000000000000 DR2=0000000500000000 DR3=0000000000000000 
DR6=00000000ffff0ff0 DR7=0000000000000400
EFER=0000000000000000
Code=c3 e8 ec ff cb f8 cb fb 80 fc 11 75 0a 0a c0 74 03 e8 dc ff <ca> 02 00 80 fc 10 74 f1 80 fc 14 74 ec 80 fc 12 75 03 e9 11 02 80 fc 16 74 0d 80 fc 46 75

Does not crash when kvm_intel is laoded with emulate_invalid_guest_state=0. 

Version-Release number of selected component (if applicable):
qemu-1.4.2-9.fc19.i686
kernel-PAE-3.10.11-200.fc19.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Cole Robinson 2013-10-31 16:59:55 EDT
Can you confirm with kernel-3.12 from rawhide?

sudo yum install fedora-release-rawhide
sudo yum --enablerepo

Also, please provide the full qemu command line. If using libvirt, provide

sudo virsh dumpxml $vmname
/var/log/libvirt/qemu/$vmname.log
Comment 2 Armands Liepins 2013-11-06 13:41:59 EST
qemu-1.4.2-12.fc19.i686
kernel-PAE-3.12.0-1.fc21.i686

$ grep "name" /proc/cpuinfo 
model name      : Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz
model name      : Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz

$ qemu-kvm -m 512 -cpu pentium -hda nw5.img

KVM internal error. Suberror: 1
emulation failure
EAX=00004600 EBX=000003c0 ECX=0000000a EDX=00000000
ESI=00000014 EDI=000003ca EBP=00000444 ESP=00000914
EIP=0000ae20 EFL=00000206 [-----P-] CPL=0 II=0 A20=1 SMM=0 HLT=0
ES =0116 00001160 0000ffff 00009300
CS =0019 00000190 0000ffff 00009b00
SS =0116 00001160 0000ffff 00009300
DS =4386 00043860 0000ffff 00009300
FS =0000 00000000 00ffffff 00c09300
GS =0000 00000000 00ffffff 00c09300
LDT=0000 00000000 0000ffff 00008200
TR =0000 00000000 0000ffff 00008b00
GDT=     00048090 0000028f
IDT=     00000000 000003ff
CR0=00000010 CR2=00000000 CR3=00000000 CR4=00000000
DR0=0000000000000000 DR1=0000000000000000 DR2=0000000500000000 DR3=0000000000000000 
DR6=00000000ffff0ff0 DR7=0000000000000400
EFER=0000000000000000
Code=b0 02 75 03 f9 b0 03 5d 5f 07 5e 1f 9f 83 c4 0e e8 f2 a1 49 <9e> c3 36 f6 06 5a 00 ff 74 6a 36 ff 36 a2 05 36 ff 36 a4 05 1e 56 5f 07 33 c0 e8 d6 fc 72
Comment 3 Armands Liepins 2013-11-08 05:59:06 EST
now crashes on 0x9e, which is sahf

(qemu) xp /8i 0x0afb0
0x000000000000afb0:  sahf   
0x000000000000afb1:  ret    
0x000000000000afb2:  testb  $0xff,%ss:0x5a
0x000000000000afb8:  je     0xb024
0x000000000000afba:  pushw  %ss:0x5a2
0x000000000000afbf:  pushw  %ss:0x5a4
0x000000000000afc4:  push   %ds
0x000000000000afc5:  push   %si

so probabbly this:
https://lkml.org/lkml/2013/10/31/254
Comment 4 Cole Robinson 2013-11-17 14:54:24 EST
Thanks for the follow up. That referenced LKML patch should be in the 3.13 kernel snapshots that are now in rawhide, can you try those on the host?
Comment 5 Armands Liepins 2013-11-20 06:34:27 EST
Installed kernel-PAE-3.13.0-0.rc0.git7.1.fc21.i686, but it behaves bad. Last bug seems is gone, but getting many "rcu_sched self-detected stall on CPU...", vm hangs at various points, sometimes even bios does not start. So have to wait for the newer kernel.
Comment 6 Cole Robinson 2013-11-20 14:29:14 EST
(In reply to Armands Liepins from comment #5)
> Installed kernel-PAE-3.13.0-0.rc0.git7.1.fc21.i686, but it behaves bad. Last
> bug seems is gone, but getting many "rcu_sched self-detected stall on
> CPU...", vm hangs at various points, sometimes even bios does not start. So
> have to wait for the newer kernel.

Thanks for testing, my guess is those other issues are just general kernel instability given that it's very early in the 3.13 cycle. But since it sounds like the reported issue is fixed with the latest kernel, I'm closing this bug. If the 3.13 issues persist with the later kernel rc releases, please file a new kernel bug.

Note You need to log in before you can comment on or make changes to this bug.