Bug 100836 - mc crashes after first command when run from virtual terminal
Summary: mc crashes after first command when run from virtual terminal
Status: CLOSED DUPLICATE of bug 101104
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: mc (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-25 21:56 UTC by Alexandre Oliva
Modified: 2015-01-08 00:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:57:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2003-07-25 21:56:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
After running any command from mc, when it's started from one of the text
consoles, mc crashes.  The same sequence doesn't crash it if it's started from
say gnome-terminal.

Version-Release number of selected component (if applicable):
mc-4.6.0-5 gpm-1.20.1-35

How reproducible:
Always

Steps to Reproduce:
1.Start mc
2.Enter `ls' as the command, then Enter

Actual Results:  The directory listing, followed by `Segmentation Fault' and a
command-line prompt from the shell that started mc.

Expected Results:  It should return to the mc prompt after running ls.

Additional info:

Any other command will do, even commands started as actions associated with
extensions.  Here's the stack trace I got from gdb:

(gdb) where
#0  0x0018e173 in strlen () from /lib/tls/libc.so.6
#1  0x0011335e in Gpm_Open () from /usr/lib/libgpm.so.1
#2  0x08072dde in strcpy ()
#3  0x0807eefb in getch ()
#4  0x0806e959 in strcpy ()
#5  0x0806eb62 in strcpy ()
[...]
#15 0x08071595 in strcpy ()
#16 0x0012c678 in __libc_start_main () from /lib/tls/libc.so.6

the several omitted occurrences of strcpy don't make much sense.  It could be
that it's just because I don't have debuginfo for these packages, but it could
also be that we have stack corruption within strcpy.  strlen() is being passed a
NULL string.

Comment 1 Bill Nottingham 2003-07-28 20:49:27 UTC
If the mc package has a rebuild date of *before* the latest slang package was
built, does rebuilding it help?

Comment 2 Alexandre Oliva 2003-07-28 21:56:59 UTC
slang adn mc in Severn is the same as in Rawhide, and mc was indeed built before
slang.  However, rebuilding mc with an `everything' install of Severn does NOT
fix the problem.

Comment 3 Alexandre Oliva 2003-07-31 05:27:10 UTC

*** This bug has been marked as a duplicate of 101104 ***

Comment 4 Leonard den Ottolander 2003-08-01 14:00:00 UTC
 Although I thought upgrading gpm to 1.20.1-36 solved this issue it did not. I
still see these crashes in mc.

 Please reopen this bug, or should I file a new one?

 I do have core files, but no idea how to analyze them. Should I attach them or
can you give me short instructions on how to debug them?


Comment 5 Leonard den Ottolander 2003-08-01 14:18:54 UTC
The problem indeed still seems to be in Gpm_Open. Got to go now, so no details
(yet).

Comment 6 Alexandre Oliva 2003-08-01 21:48:11 UTC
It sure solves the problem that I reported.  If you still have problems, please
file a new bug report describing how to duplicate it.

Comment 7 Leonard den Ottolander 2003-08-01 22:38:05 UTC
For you it might have solved this issue, but I still see this:

(gdb) bt
#0  0x00ef7173 in strlen () from /lib/tls/libc.so.6
#1  0x002c73e2 in Gpm_Open () from /usr/lib/libgpm.so.1
#2  0x08072dde in strcpy ()
#3  0x0807eefb in getch ()
#4  0x0806e959 in strcpy ()
#5  0x0806eb62 in strcpy ()
#6  0x0806ebb9 in strcpy ()
#7  0x08055df3 in strcpy ()
#8  0x080706ce in strcpy ()
#9  0x0805a8bc in strcpy ()
#10 0x0805aaa9 in strcpy ()
#11 0x0805afef in strcpy ()
#12 0x0805abac in strcpy ()
#13 0x08070a76 in strcpy ()
#14 0x08070c6a in strcpy ()
#15 0x08071595 in strcpy ()
#16 0x00e95678 in __libc_start_main () from /lib/tls/libc.so.6

Looks quite similar to the problem you are describing wouldn't you say?


Comment 8 Alexandre Oliva 2003-08-02 11:19:35 UTC
Hmm...  Interesting.  The problem is gone on my desktop, but indeed I can still
duplicate it on my laptop.  Still, this is probably still a duplicate of bug
101104, so let's keep it closed as a duplicate until it is resolved.

Comment 9 Red Hat Bugzilla 2006-02-21 18:57:44 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.