Bug 1008377 - rhev-h auto install failed during create_hostvg for iscsi boot
rhev-h auto install failed during create_hostvg for iscsi boot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: Regression, TestBlocker
Depends On:
Blocks: 1094622
  Show dependency treegraph
 
Reported: 2013-09-16 05:47 EDT by haiyang,dong
Modified: 2014-05-06 03:21 EDT (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-4.el6
Doc Type: Bug Fix
Doc Text:
--no tech note required
Story Points: ---
Clone Of:
: 1094622 (view as bug list)
Environment:
Last Closed: 2014-01-21 14:50:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot (26.17 KB, image/png)
2013-09-16 05:47 EDT, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2013-09-16 05:47:17 EDT
Created attachment 798196 [details]
attached Screenshot

Description of problem:
RHEV-H auto install failed during create_hostvg for iscsi boot with the follow parameter:
BOOTIF=eth0 storage_init=/dev/vda,/dev/sda iscsi_init=/dev/sda iscsi_target_name=iqn.2013-01.com:hadong iscsi_install iscsi_server=10.66.11.127:3260 firstboot

it auto install failed with follow infoseen ovirt-node.log.png)
parted "/dev/mapper/1IET_00010001" -s "mkpart primary ext2 512M -1"
Error:You requested a partition from 512MB to 32.2GB
The closest location we can manage is 1024MB to 32.2GB

Maybe change the follow code can resole this issue.
[root@agent2 ovirtnode]# diff storage.py storage.py.backup 
436,437c436
<                                   "primary ext2 " + str(self.ROOT_SIZE * 2) +
<                                   " -1\"")
---
>                                   "primary ext2 512M -1\"")


Version-Release number of selected component (if applicable):
ovirt-node-iso-3.1.0-0.999.625.el6.iso

How reproducible:
100%

Steps to Reproduce:


Actual results:


Expected results:


Additional info:
no this issue in rhev-h 6.4.z, so it's a regression bug.
Comment 3 haiyang,dong 2013-09-17 01:54:18 EDT
Test version:
rhev-hypervisor6-6.5-20130916.0.el6ev.iso
ovirt-node-3.0.1-1.el6

Could reproduce "rhev-h auto install failed during create_hostvg for iscsi boot"
issue.
Comment 4 haiyang,dong 2013-09-17 02:05:30 EDT
Hey, jboggs,

My patch: 
http://gerrit.ovirt.org/#/c/19271/
just fixed the create_hostvg issue during rhev-h auto install.

i'll meet another issue for iscsi boot during rhev-h auto install. I add "TestBlocker" into "Keywords" because "iscsi boot" is an important feature for rhev-h 6.5.

Could you look at this bug?
Comment 9 haiyang,dong 2013-10-09 05:11:22 EDT
Test version:
rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso        
ovirt-node-3.0.1-3.el6.noarch

This bug has been fixed by above auto jenkins build. rhev-h auto install success for iscsi boot.Also boot it and login rhev-h success.
I am waiting office build to verify this bug.
Comment 10 haiyang,dong 2013-10-18 06:53:13 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6

Test steps:
BOOTIF=eth0 storage_init=/dev/sda,/dev/sdb iscsi_init=/dev/sdb iscsi_target_name=iqn.2013-01.com:hadong iscsi_install iscsi_server=10.66.11.127:3260 firstboot

Test results:
rhev-h auto install success for iscsi boot.Also boot it and login rhev-h success.
so this bug has been fixed.
After this status of bug changed from "MODIFIED" to "ON_QA", i will verify this bug.
Comment 11 haiyang,dong 2013-10-19 02:45:28 EDT
According to Comment 10, verified this bug.
Comment 13 Cheryn Tan 2013-11-07 19:28:40 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 16 errata-xmlrpc 2014-01-21 14:50:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.