Bug 1008404 - 4.4.3. Configuring Servers for Enhanced Entitlements Reporting - step 6. addition: chown -R swreport:swreport /home/swreport/.ssh
4.4.3. Configuring Servers for Enhanced Entitlements Reporting - step 6. addi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Installation Guide (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Macpherson
Dan Macpherson
:
Depends On:
Blocks: sat560-docs
  Show dependency treegraph
 
Reported: 2013-09-16 06:15 EDT by Jan Hutař
Modified: 2013-10-11 08:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-11 08:38:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-09-16 06:15:39 EDT
Description of problem:
In the documentation we advise to create /home/swreport/.ssh and /home/swreport/.ssh/authorized_keys, but when blindly following the guide, you end up with /home/swreport/.ssh owned by root and not swreport user.


Expected results:
IMO into the step 7, something like this should be appended:

# chown -R swreport:swreport /home/swreport/.ssh
Comment 3 Clifford Perry 2013-10-11 08:38:18 EDT
https://access.redhat.com/site/documentation/en-US/Red_Hat_Satellite/5.6/html-single/Installation_Guide/index.html

Step 6 and 7 read: 

6. Prepend the SAM public key content in /home/swreport/.ssh/authorized_keys with the following:

command="/usr/bin/spacewalk-report $SSH_ORIGINAL_COMMAND"

7. This ensures the swreport user only uses the spacewalk-report command.
Set permissions and the SELinux content on the .ssh directory and authorized_keys file for the swreport user.

[root@sat56] # chown -R swreport:swreport /home/swreport/.ssh
[root@sat56] # chmod 700 /home/swreport/.ssh
[root@sat56] # chmod 600 /home/swreport/.ssh/authorized_keys
[root@sat56] # restorecon -R /home/swreport/.ssh

Looks good to myself (usage of -R is OK, since directory shouldn't have anything but standard stuff). 

Cliff

Note You need to log in before you can comment on or make changes to this bug.