Bug 1008426 - Input error not shown in edit VM/Template dialog when advanced options are hidden
Input error not shown in edit VM/Template dialog when advanced options are hi...
Status: CLOSED DUPLICATE of bug 1085380
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity medium
: ---
: 3.5.0
Assigned To: Tomas Jelinek
Pavel Stehlik
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 06:57 EDT by tgeft
Modified: 2014-04-10 03:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-10 03:09:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tgeft 2013-09-16 06:57:43 EDT
Description of problem:
If one of the fields in the advanced options (System, initial run, ...) of the VM/template dialog is incorrect and the user has hidden the advanced options, the error will not be visible to the user when clicking OK. To see the problematic field, the user will have to click "Show Advanced Options". 


Version-Release number of selected component (if applicable):
3.3.0-0.21.master.el6ev

How reproducible:
100%

Steps to Reproduce:

Simple artificial scenario:
1. Enter the new VM dialog, open the advanced options, and input 0 in the 'Total Virtual CPUs' field (under 'System').
2. Hide the advanced options and click OK

More realistic scenario:
1. Edit a VM to run on host X in the host placement option (choose "specific" -> host X) and click OK.
2. Move the host to another DC.
3. Try to edit the VM's name and click OK. (without expanding the advanced options)

Actual results:
In both cases clicking OK will result in no apparent action nor error. The user will have to look at the advanced options to find the problematic field.

Expected results:
The advanced options should expand automatically to allow the user to see the error. Alternatively, bring up an error dialog about the problematic field.


Additional info:
Comment 2 Tomas Jelinek 2014-04-10 03:09:05 EDT

*** This bug has been marked as a duplicate of bug 1085380 ***

Note You need to log in before you can comment on or make changes to this bug.