Bug 1008481 - Undeployment failure notification duplicated
Undeployment failure notification duplicated
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
unspecified
Unspecified Unspecified
low Severity low
: ER5
: 6.0.0
Assigned To: Maciej Swiderski
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 09:07 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:12:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuzana Krejčová 2013-09-16 09:07:45 EDT
Description of problem:
If an undeploy operation fails, you now get two notifications. One in the Uberfire alert pop-up that quickly disappears, one in the Problems tab, that appeared in the Deployments perspective in this build.

There is no need to tell the user twice. The Problems tab is better for this, I think, since the information stays, so the user has time to read it. It also doesn't cover the menu bar the way the Uberfire notifications do.

Please, only provide one type of notification.


Version-Release number of selected component (if applicable):
BPMS 6.0 ER3
Comment 1 Maciej Swiderski 2013-09-23 07:24:56 EDT
Zuzana, the idea of having this information sort of duplicated is because Problems panel could be:
- closed (as user might close it)
- not visible (very on the bottom of the page)

and thus giving a short "fly over" notification might be very useful when looking for what happened. It's not meant to provide user with detailed information what went wrong but more of indicating that it failed. To be consistent with success notification. Removing this notification might lead to more issues when when having it as duplicate.

wdyt?
Comment 2 Zuzana Krejčová 2013-09-23 08:07:40 EDT
(In reply to Maciej Swiderski from comment #1)
> Zuzana, the idea of having this information sort of duplicated is because
> Problems panel could be:
> - closed (as user might close it)
> - not visible (very on the bottom of the page)
> 
> and thus giving a short "fly over" notification might be very useful when
> looking for what happened. It's not meant to provide user with detailed
> information what went wrong but more of indicating that it failed. To be
> consistent with success notification. Removing this notification might lead
> to more issues when when having it as duplicate.
> 
> wdyt?

Well, that sounds reasonable. In this case, I think it would be even better if the "fly over" notification was really short - like "Undeployment failed." - and have some reason for this in the Problems panel. 
It is quite hard to catch anything more than that from the "fly over" notification anyway. As a user, it makes me a bit nervous that there is some kind of notification and I cannot read it all, because it disappears before I finish reading it.

Would it be possible to bring up the Problems panel in the Deployments perspective in case of various failures? So that, if something went wrong, user would get the short notification and even if he closed the Problems panel earlier, he could then look for more information in there, as it would be brought up again (the short notification then serving as a kind of a pointer that "hey, something's wrong, look at the bottom").

I don't think that those "fly over" notifications are very good for detailed information, so keeping those messages as short as possible might still be best, if we can give the details some other way.

This would probably apply to manual deployment of units as well btw.
Comment 3 Maciej Swiderski 2013-09-23 08:17:34 EDT
+1 for making the "fly over" notification to just indicate that state of the deployment (Success or Failure) and then the problems panel would contain details.

I'll check if we can reopen the problems panel in case of an error although it might be bit annoying if someone closed it explicitly and we force it to reopen.

Build & deploy and manual deployments rely on the same services so change in one place will apply to both.
Comment 4 Maciej Swiderski 2013-09-24 12:03:25 EDT
updated notification to contain only information about the failure and reference to problems panel.

master
https://github.com/droolsjbpm/jbpm-console-ng/commit/0813713c5f9b4a79ce7ac0142202723a9a4ee3e3

6.0.x
https://github.com/droolsjbpm/jbpm-console-ng/commit/d98ffcc98990ef71b2442274a00122b062d3ca41

since user can decide to close the Problems panel we should not reopen it and thus marking it as modified for now. If there will be explicit need to reopen it we can revisit this case.
Comment 5 Zuzana Krejčová 2013-10-29 11:12:14 EDT
New deployment errors are fixed, undeploy errors are not (the same should be done for them).
Comment 6 Maciej Swiderski 2013-10-29 12:06:41 EDT
Zuzana, could you please provide bit more information on what is missing and what undeployment errors you have seen? What I was able to check was that when you try to undeploy deployment that has active process instances then the error will be present in "Problems" panel.
Comment 7 Zuzana Krejčová 2013-10-30 04:32:19 EDT
(In reply to Maciej Swiderski from comment #6)
> What I was able to check was that
> when you try to undeploy deployment that has active process instances then
> the error will be present in "Problems" panel.

That's exactly it. There's the error in the Problems panel and the user also gets pretty much the same, long message via the UberFire "fly over" notification.

Your commit only changed the ....deployment.newunit.NewDeploymentPresenter. The same should be done for ....deployment.list.DeploymentUnitsListPresenter. There is still this (line 126 on current 6.0.x branch):
   view.displayNotification( "Error: Undeploy failed " + throwable.getMessage() );
whereas the fixed code for ....deployment.newunit.NewDeploymentPresenter has this for the "fly over" notification:
   view.displayNotification( "Error: Deploy failed, check Problems panel " );

Note You need to log in before you can comment on or make changes to this bug.