This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1008493 - libreport contains two plugins to reporting to bugzilla on Live
libreport contains two plugins to reporting to bugzilla on Live
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 09:26 EDT by Kamil Páral
Modified: 2016-11-30 19:45 EST (History)
15 users (show)

See Also:
Fixed In Version: gnome-abrt-0.3.2-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-13 15:49:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libreport on Live - duplicated options (46.71 KB, image/png)
2013-09-16 09:26 EDT, Kamil Páral
no flags Details
libreport on DVD - a single option (48.42 KB, image/png)
2013-09-16 09:27 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-09-16 09:26:56 EDT
Created attachment 798283 [details]
libreport on Live - duplicated options

Description of problem:
When Anaconda crashes on LiveCD, there is one option to upload the report to a custom server and two options to report the bug to bugzilla. See screenshot. Those two options are extremely similar and they are very confusing. In the end, both are the same (I think!), but users don't know that.

I believe one of those options comes from libreport-anaconda and one of them from libreport-plugin-bugzilla. I wonder, why does Anaconda have a custom plugin instead of using the common one?

This does not happen on DVD (I guess because libreport-plugin-bugzilla is not there).


Version-Release number of selected component (if applicable):
F20 Alpha RC2
anaconda 20.15
libreport-2.1.6-2.fc20.x86_64
libreport-anaconda-2.1.6-2.fc20.x86_64
libreport-cli-2.1.6-2.fc20.x86_64
libreport-fedora-2.1.6-2.fc20.x86_64
libreport-filesystem-2.1.6-2.fc20.x86_64
libreport-gtk-2.1.6-2.fc20.x86_64
libreport-plugin-bugzilla-2.1.6-2.fc20.x86_64
libreport-plugin-kerneloops-2.1.6-2.fc20.x86_64
libreport-plugin-logger-2.1.6-2.fc20.x86_64
libreport-plugin-reportuploader-2.1.6-2.fc20.x86_64
libreport-plugin-ureport-2.1.6-2.fc20.x86_64
libreport-python-2.1.6-2.fc20.x86_64
libreport-web-2.1.6-2.fc20.x86_64


How reproducible:
always

Steps to Reproduce:
1. boot Live
2. make anaconda crash (kill -USR1 `cat /var/run/anaconda.pid`)
3. hit Report

Actual results:
2 options to report to bugzilla, confusingly same

Expected results:
1 option to report to bugzilla


Additional info:
When you're at it, can you please make the bugzilla option the topmost one? It makes much more sense. Thanks.
Comment 1 Kamil Páral 2013-09-16 09:27:26 EDT
Created attachment 798285 [details]
libreport on DVD - a single option
Comment 2 Vratislav Podzimek 2013-09-23 11:03:16 EDT
There's nothing that can be done on the anaconda's side to fix this issue. Reassigning to libreport. I've discussed this with jfilak and it seems that the solution could be splitting the libreport-anaconda package into two. Some changes in lorax templates and spin kickstarts may be needed afterwards.
Comment 3 Vratislav Podzimek 2013-09-23 14:09:35 EDT
I can confirm that jfilak's patch for this issue works.
Comment 4 Jakub Filak 2013-09-24 02:59:25 EDT
(In reply to Vratislav Podzimek from comment #3)
Thank you for testing! I've created a pull request for the patch.

https://github.com/abrt/libreport/pull/184
Comment 5 Jakub Filak 2013-09-24 07:33:49 EDT
Upstream commit 4418416621d64995da50bb7381a9433ef5e85f0c fixes this bug.
Comment 6 Fedora Update System 2013-10-11 06:42:39 EDT
gnome-abrt-0.3.2-1.fc20,abrt-2.1.8-1.fc20,libreport-2.1.8-1.fc20,satyr-0.10-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gnome-abrt-0.3.2-1.fc20,abrt-2.1.8-1.fc20,libreport-2.1.8-1.fc20,satyr-0.10-1.fc20
Comment 7 Fedora Update System 2013-10-11 12:50:10 EDT
Package gnome-abrt-0.3.2-1.fc20, abrt-2.1.8-1.fc20, libreport-2.1.8-1.fc20, satyr-0.10-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-0.3.2-1.fc20 abrt-2.1.8-1.fc20 libreport-2.1.8-1.fc20 satyr-0.10-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18868/gnome-abrt-0.3.2-1.fc20,abrt-2.1.8-1.fc20,libreport-2.1.8-1.fc20,satyr-0.10-1.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-10-13 15:49:11 EDT
gnome-abrt-0.3.2-1.fc20, abrt-2.1.8-1.fc20, libreport-2.1.8-1.fc20, satyr-0.10-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.