Bug 1008502 - Keyboard layout has been wrong ever since Fedora 18,
Keyboard layout has been wrong ever since Fedora 18,
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
22
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 09:40 EDT by Leslie Satenstein
Modified: 2015-04-05 09:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-05 09:41:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Physical Keboard layout CA(fr) (127.35 KB, image/png)
2013-09-16 09:40 EDT, Leslie Satenstein
no flags Details
USA English Keyboard Layout (74.02 KB, image/png)
2013-09-16 09:41 EDT, Leslie Satenstein
no flags Details
Latin American Keyboard layout showing full keyboard layout (71.27 KB, image/png)
2013-09-16 09:43 EDT, Leslie Satenstein
no flags Details
/usr/share/X11/xkb/symbols/ca with permenant Euro and perm yen symbols (21.00 KB, text/plain)
2014-03-05 09:59 EST, Leslie Satenstein
no flags Details

  None (edit)
Description Leslie Satenstein 2013-09-16 09:40:02 EDT
Created attachment 798287 [details]
Physical Keboard layout CA(fr)

Description of problem:

Attached are three images for the USA English / Canadian French and the Latin American (latam) keyboards. These layouts are from Fedora 17.

Between the left shift-key and the Z key, is one additional key that is not shown on the Fedora 18,19,20 layouts.  I have made this request to fix this error since the Alpha version of Fedora 18, (2 years already)



Version-Release number of selected component (if applicable):

Rawhide, Fedora 20, Fedora 19, and Fedora 18.



How reproducible:

Select the USA keyboard, or the CA(FR) or Latam Keyboard from the aforementioned Fedora versions and compare to the attached layouts.


Steps to Reproduce:
1.
2.
3.

Actual results:

Keytop missing, with language specific characters.  I cannot display «»°¦ which are resident on the omitted keytop.

Expected results:

Expect keyboard layouts to reflect what is actually a representation of the physical keyboard. 

Additional info:
Comment 1 Leslie Satenstein 2013-09-16 09:41:46 EDT
Created attachment 798288 [details]
USA English Keyboard Layout
Comment 2 Leslie Satenstein 2013-09-16 09:43:30 EDT
Created attachment 798289 [details]
Latin American Keyboard layout showing full keyboard layout

Refer to bug reports 798287 798288
Comment 3 Parag Nemade 2013-09-17 01:55:54 EDT
ah! I see these 798287 798288  bugs are not related to this bug. The real bug numbers are 880494 and 866887
Comment 4 Leslie Satenstein 2014-01-18 19:21:21 EST
Well,suddenly today entire keyboardmappingappearsfaulty.Iam using
or US English,and-the-mappings-have-failed.

The ENGLISH AND FRENCH KEYBOARD LAYOUTS NO LONGER UNDERSTAND LOWER CASE SPACE BAR AND DO NOT RECOGNIZE THE GNOME TWEAK SETTINGS TO ENABLE THE EURO SYMBOL. THE EURO SYMBOL FOR CANADIAN FRENCH KEYBOARDS SOLD BY THE STORES (MICROSOFT CANADIAN FRENCH LAYOUT) HAS THE EURO ON THE E KEY AS RIGHT_ALT_E AND THE RUPEE AS RIGHT_ALT_5 KEY.  THIS PROBLEM IS RECENT (TODAYA).I THEREFORE HAVE NO ABILITY TO USE LOWER CASE LETTERS OR TO TYPE THE EURO SYMBOL.

IF HOWEVER I ENABLE (VIA THE TWEAK TOOL' TYPING==> ENABLE EXTRA CHARACTERS,THEN I GAIN THE EURO € and LOSE THE TILDA (HOME SYMBOL) .


THIS PROBLEM IS NEW AND ON TWO INDEPENDENT COMPUTERS WITH TWO INDEPENDENT FEDORA 20 INSTALLATIONS.  ONLY DIFFERENCES __ GIT IS INSTALLED ON COMPUTER A.

PLEASE HELP' ALSO PLEASE SHOW THE CORRECT KEYBOARD LAYOUT AS ONLY THE USA PHYSICAL KEYBOARD LAYOUT IS SHOWN. ON MINT16 OR WITH FEDORA 17, THE CORRECT PC105 KEYBOARD IS SHOWN WITH THAT EXTRA KEY BETWEEN THE Z AND THE LEFT UPPER CASE SHIFT KEY.
Comment 5 Leslie Satenstein 2014-03-05 09:59:15 EST
Created attachment 871000 [details]
/usr/share/X11/xkb/symbols/ca with permenant Euro and perm yen symbols

What I had to do to bring the keyboard layout up to date to include the Euro and the yen, two currencies that are now used by over 1500 million people.
Comment 6 Leslie Satenstein 2014-10-11 12:33:56 EDT
PC105 is the physical keyboard that is not showing.
Comment 7 Leslie Satenstein 2015-01-13 16:22:53 EST
Same problem (carry over from F19, F20) 

Will this ever get fixed. Ubuntu has correct layout (Debian), so does SUSE and Centos6.5
Comment 8 Leslie Satenstein 2015-01-24 08:48:18 EST
The solution to this problem is relatively easy 
When we select the keyboard with anaconda (or with gnome -keyboard application)
the check should be made to determine if the layout is pc104 or pc105

For example

localectl set-x11-keymap ca pc105  setups up the proper keyboard layout.

for the latin American keyboard layout

localectl set-x11 keymap latam pc105 


Anaconda and Gnome need to include the missing parameter

 set-x11-keymap LAYOUT [MODEL [VARIANT [OPTIONS]]]
           Set the system default keyboard mapping for X11. This takes a
           keyboard mapping name (such as "de" or "us"), and possibly a model,
           variant and options, see kbd(4) for details. Unless --no-convert is
           passed, the selected setting is also applied to the system console
           keyboard mapping, after converting it to the closest matching
           console keyboard mapping.
Comment 9 Leslie Satenstein 2015-02-13 17:11:36 EST
Please correct.  Many countries standard keyboard is pc105.

I posted the correction in comment 8.   Surely it does not take 4 releases to fix a wrong representation.     
Open SUSE, Fedora's competitor gets it right.  It was correct before Fedora 18
Comment 10 Leslie Satenstein 2015-03-04 09:58:41 EST
Please correct. This problem has been outstanding since Fedora18
Comment 11 Leslie Satenstein 2015-04-05 09:41:54 EDT
Fedora 21 and Fedora 22 have the correction implemented. 

Thank you

Note You need to log in before you can comment on or make changes to this bug.