Bug 1008504 - when exporting "Red Hat Default Report" for organization with double quotes (") in name, columns do not match
when exporting "Red Hat Default Report" for organization with double quotes (...
Status: CLOSED WONTFIX
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Splice Developers
mkovacik
:
Depends On: 1003625
Blocks: sam20-tracker
  Show dependency treegraph
 
Reported: 2013-09-16 09:41 EDT by Jan Hutař
Modified: 2017-06-26 16:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1003625
Environment:
Last Closed: 2017-06-26 16:34:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-09-16 09:41:45 EDT
Creating new bug for this issue.

+++ This bug was initially created as a clone of Bug #1003625 +++

Description of problem:
I have organization "Red Hat, Inc." synced from Satellite 5.6.0 through Splice and when I attempt to read export.csv from report "Red Hat Default Report", columns are broken.


Version-Release number of selected component (if applicable):
SAM 1.3 snapshot #4
ruby193-rubygem-splice_reports-0.0.8-1.el6sam.noarch
katello-glue-elasticsearch-1.4.3-11.el6sam_splice.noarch
spacewalk-splice-tool-0.40-1.el6sam.noarch
katello-common-1.4.3-11.el6sam_splice.noarch
katello-headpin-1.4.3-11.el6sam_splice.noarch
splice-common-config-0.144-1.el6sam.noarch
splice-selinux-0.144-1.el6sam.noarch
splice-common-0.144-1.el6sam.noarch
ruby193-rubygem-splice_reports-0.0.8-1.el6sam.noarch
katello-headpin-all-1.4.3-11.el6sam_splice.noarch
katello-glue-candlepin-1.4.3-11.el6sam_splice.noarch
splice-0.144-1.el6sam.noarch


How reproducible:
always


Steps to Reproduce:
1. Have Satellite 5.6.0 with NULL organization named "Red Hat, Inc."
2. Use Splice to sync it to SAM 1.3
3. Use webUI to download archive with the export:
   Administer -> Red Hat Default Report -> Export Report
4. Look at the report's export.csv in the LibreOffice


Actual results:
Last 2 columns are moved, incorrect data in it. This is caused by incorrect escaping of strings - looking into export.csv:
[...]ibm-x3655-02.ovirt.rhts.eng.bos.redhat.com, Red Hat, Inc., Active, 


Expected results:
[...]ibm-x3655-02.ovirt.rhts.eng.bos.redhat.com,"Red Hat, Inc.", Active,

[...]
--- Additional comment from Jan Hutař on 2013-09-16 06:41:00 EDT ---

FAILS_QA

Please try with system named like:

"ahoj"

(including these quotes). You will get CSV file like:

{"ident"=>"27c33d36-0599-4220-9b27-3207f418a2db"}, 5236de8841905d6c59000006, 2013-09-16T10:31:43Z, "Current", "27c33d36-0599-4220-9b27-3207f418a2db", "ibm-x3650m4-03-vm08.lab.eng.brq.redhat.com", 1000010001, ""ahoj"", "Red Hat, Inc.", "Active", 

So columns do not match again. Now there is one column less in LibreOffice.

--- Additional comment from Jan Hutař on 2013-09-16 06:41:35 EDT ---

Sorry, forgot to mention: used SAM 1.3 snapshot #6 as well.

--- Additional comment from Vitaly Kuznetsov on 2013-09-16 09:16:05 EDT ---

I would suggest creating new issue for quotes as original one was for commas.
Comment 1 Bryan Kearney 2017-06-26 16:34:08 EDT
The release of Satellite 5.8 we are deprecating the support of Subscription Asset Manager. The release notes for 5.8 can be found at https://access.redhat.com/documentation/en-us/red_hat_satellite/5.8/pdf/release_notes/Red_Hat_Satellite-5.8-Release_Notes-en-US.pdf.

I am therefore closing out this bug as WONTFIX. If you believe this to be an error, please feel free tor each out to either Rich Jerrido or Bryan Kearney. Thank you!

Note You need to log in before you can comment on or make changes to this bug.