Bug 1008554 - Missing javadoc for org.jboss.xts
Missing javadoc for org.jboss.xts
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Other (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: CR1
: EAP 6.2.0
Assigned To: Yong Yang
Jakub Cechacek
:
Depends On: 1026701
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 11:09 EDT by Jakub Cechacek
Modified: 2015-02-01 18:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:23:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Cechacek 2013-09-16 11:09:52 EDT
Current javadoc is missing documentation for following jars and packages 

/home/jcechace/tools/eap/eap6/620/jboss-eap-6.2/modules/system/layers/base/org/jboss/xts/main/jbossxts-4.17.9.Final-redhat-1.jar
1 missing:
   org.jboss.jbossts.xts.bridge.at
/home/jcechace/tools/eap/eap6/620/jboss-eap-6.2/modules/system/layers/base/org/jboss/xts/main/jbosstxbridge-4.17.9.Final-redhat-1.jar
3 missing:
   org.jboss.jbossts.txbridge.outbound
   org.jboss.jbossts.txbridge.inbound
   org.jboss.jbossts.txbridge.utils
Comment 1 Misty Stanley-Jones 2013-10-09 23:16:56 EDT
I'm not sure what the right component is for Javadoc bugs, but Documentation should be used for formal documentation maintained by Content Services. Javadoc does not fall under this category. Maybe we need a new component for it?
Comment 2 Yong Yang 2013-10-12 04:14:29 EDT
This artifact was excluded from javadoc generation before 6.2.0 due to some error. Now it has been fixed in Jenkins, https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/EAP6-javadoc/75/, and will be included in next ER. 


FYI:
$ cat build/javadoc/artifactsBlacklist.txt 
org.jboss.as:jboss-as-controller-client
org.jboss:jboss-dmr
org.jboss.jbossts:jbossxts
org.jboss.jbossts:jbossxts-api
org.jboss.weld:weld-core
org.picketbox:picketbox-commons
xalan:serializer
org.apache.ws.security:wss4j
Comment 3 Yong Yang 2013-10-18 06:24:43 EDT
These javadocs are generated in EAP6.2.0 ER6.
Comment 4 Jakub Cechacek 2013-10-22 03:39:18 EDT
The following package still remains missing in docs for 6.2.0.ER6

/home/jcechace/tools/eap/eap6/620/er6/jboss-eap-6.2/modules/system/layers/base/org/jboss/xts/main/jbossxts-4.17.12.Final-redhat-1.jar
1 missing:
   org.jboss.jbossts.xts.bridge.at
Comment 5 Yong Yang 2013-10-24 01:39:20 EDT
No org/jboss/jbossts/xts/bridge/ in jbossxts sources jar, need to rebuild  org.jboss.jbossts-narayana-all to solve this issue.


[yyang@dhcp-17-104 javadoc-er6]$ jar tf localRepo/org/jboss/jbossts/xts/jbossxts/4.17.12.Final-redhat-1/jbossxts-4.17.12.Final-redhat-1.jar | grep bridge
org/jboss/jbossts/xts/bridge/
org/jboss/jbossts/xts/bridge/at/
org/jboss/jbossts/xts/bridge/at/BridgeWrapper.class
META-INF/maven/org.jboss.jbossts.xts/bridge/
META-INF/maven/org.jboss.jbossts.xts/bridge/pom.xml
META-INF/maven/org.jboss.jbossts.xts/bridge/pom.properties

[yyang@dhcp-17-104 javadoc-er6]$ jar tf localRepo/org/jboss/jbossts/xts/jbossxts/4.17.12.Final-redhat-1/jbossxts-4.17.12.Final-redhat-1-sources.jar | grep bridge
[yyang@dhcp-17-104 javadoc-er6]$
Comment 6 Vladimir Dosoudil 2013-10-24 03:13:22 EDT
The source for BridgeWrapper is located in corresponding maven (sub-)module (../bridge/). Including BridgeWrapper.class in jbossxts artifact is configured by using maven-shade-plugin.
Comment 7 Yong Yang 2013-11-04 21:46:44 EST
Hi Vladimir, to keep the sources jar and binary jar consistent, is it possible to remove BridgeWrapper.class from binary jar or add BridgeWrapper.java to sources jar?
Comment 8 Vladimir Dosoudil 2013-11-05 02:48:17 EST
Optional parameter createSourcesJar has been added into configuration of maven-shade-plugin for jbossxts. Fixed jbossxts source jar will be available in the next builds of jbossts/narayana i.e. newer than 4.17.15.Final-redhat-1.
Comment 9 Vladimir Dosoudil 2013-11-05 06:34:55 EST
jbossxts sources jar fixed in https://brewweb.devel.redhat.com/buildinfo?buildID=306066
Comment 10 Jakub Cechacek 2013-11-14 06:19:14 EST
Verified 6.2.0.CR1

Note You need to log in before you can comment on or make changes to this bug.