Bug 1008555 - Missing javadoc for org.picketlink and org.picketbox
Missing javadoc for org.picketlink and org.picketbox
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Other (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER6
: EAP 6.2.0
Assigned To: Yong Yang
Jakub Cechacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 11:10 EDT by Jakub Cechacek
Modified: 2015-02-01 18:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:18:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Cechacek 2013-09-16 11:10:01 EDT
Current javadoc is missing documentation for following jars and packages 

/home/jcechace/tools/eap/eap6/620/jboss-eap-6.2/modules/system/layers/base/org/picketbox/main/picketbox-commons-1.0.0.final-redhat-2.jar
2 missing:
   org.picketbox.commons.ssl
   org.picketbox.commons.cipher
/home/jcechace/tools/eap/eap6/620/jboss-eap-6.2/modules/system/layers/base/org/picketlink/main/picketlink-jbas7-2.1.6.3.Final-redhat-2.jar
14 missing:
   org.picketlink.identity.federation.bindings.jboss.auth
   org.picketlink.identity.federation.bindings.jboss.subject
   org.picketlink.identity.federation.bindings.tomcat
   org.picketlink.trust.jbossws.handler
   org.picketlink.identity.federation.bindings.jboss.auth.mapping
   org.picketlink.identity.federation.bindings.jboss.attribute
   org.picketlink.trust.jbossws
   org.picketlink.trust.jbossws.util
   org.picketlink.trust.jbossws.jaas
   org.picketlink.identity.federation.bindings.tomcat.sp
   org.picketlink.identity.federation.bindings.tomcat.idp
   org.picketlink.identity.federation.bindings.util
   org.picketlink.identity.federation.bindings.tomcat.sp.holder
   org.picketlink.identity.federation.bindings.servlets
Comment 1 Misty Stanley-Jones 2013-10-09 23:16:51 EDT
I'm not sure what the right component is for Javadoc bugs, but Documentation should be used for formal documentation maintained by Content Services. Javadoc does not fall under this category. Maybe we need a new component for it?
Comment 2 Yong Yang 2013-10-12 04:12:31 EDT
This artifact was excluded from javadoc generation before 6.2.0 due to some error. Now it has been fixed in Jenkins, https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/EAP6-javadoc/75/, and will be included in next ER. 


FYI:
$ cat build/javadoc/artifactsBlacklist.txt 
org.jboss.as:jboss-as-controller-client
org.jboss:jboss-dmr
org.jboss.jbossts:jbossxts
org.jboss.jbossts:jbossxts-api
org.jboss.weld:weld-core
org.picketbox:picketbox-commons
xalan:serializer
org.apache.ws.security:wss4j
Comment 3 Yong Yang 2013-10-18 06:23:56 EDT
These javadocs are generated in EAP6.2.0 ER6.
Comment 4 Jakub Cechacek 2013-10-22 03:42:43 EDT
verified 6.2.0.ER6

Note You need to log in before you can comment on or make changes to this bug.