Bug 1008611 - In JBDSIS 7.0.0.beta2 - The SOA5 category includes Drools6 which may be incompatible with BRMS5 and SOA5
In JBDSIS 7.0.0.beta2 - The SOA5 category includes Drools6 which may be incom...
Status: CLOSED NOTABUG
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Paul Leacu
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 12:59 EDT by Len DiMaggio
Modified: 2013-09-25 08:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 13:57:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (56.51 KB, image/png)
2013-09-16 13:51 EDT, Len DiMaggio
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker jbtis-178 Major Resolved In JBTIS 4.1.3.beta2 - The SOA5 category includes Drools6 which may be incompatible with BRMS5 and SOA5 2013-09-25 10:05:12 EDT

  None (edit)
Description Len DiMaggio 2013-09-16 12:59:31 EDT
Description of problem:


https://issues.jboss.org/browse/JBTIS-178

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 JBoss JIRA Server 2013-09-16 13:17:48 EDT
Paul Leacu <pleacu@redhat.com> made a comment on jira JBTIS-178

JBDSIS 7.0.0.Beta2 p2 update site installation screen capture.
Comment 2 JBoss JIRA Server 2013-09-16 13:19:45 EDT
Paul Leacu <pleacu@redhat.com> made a comment on jira JBTIS-178

Hey Kris -
       The question is:

   Will the 6.0.0 JBoss Drools works okay with the SOA 5.x compatibility installation (any server incompatibilities, etc)?

     Thanks
Comment 3 Len DiMaggio 2013-09-16 13:51:49 EDT
Created attachment 798380 [details]
Screenshot
Comment 4 JBoss JIRA Server 2013-09-16 18:15:57 EDT
Kris Verlaenen <kris.verlaenen@gmail.com> made a comment on jira JBTIS-178

The idea is that the Drools & jBPM plugins would support older versions too.  So, based on the ability to configure your own runtime and backwards compatibility of resource files, that should be possible.
Comment 5 JBoss JIRA Server 2013-09-17 04:00:35 EDT
Lukáš Petrovický <lpetrovi@redhat.com> made a comment on jira JBTIS-178

Kris, correct me if I'm wrong, but isn't 6.0 always used for rule validation inside the editor etc.?
Comment 6 JBoss JIRA Server 2013-09-18 13:07:38 EDT
Paul Leacu <pleacu@redhat.com> made a comment on jira JBTIS-178

Any more discussion on this one?  Given the component tech leads comments and the fact that is assigned back to me - I plan on closing this JIRA tomorrow if there are no further comments.
Comment 7 JBoss JIRA Server 2013-09-23 10:16:54 EDT
Paul Leacu <pleacu@redhat.com> updated the status of jira JBTIS-178 to Resolved
Comment 8 JBoss JIRA Server 2013-09-23 10:16:54 EDT
Paul Leacu <pleacu@redhat.com> made a comment on jira JBTIS-178

From Kris - there is no issue - the current drools/jBPM has backward compatibility built into them:

The idea is that the Drools & jBPM plugins would support older versions too. So, based on the ability to configure your own runtime and backwards compatibility of resource files, that should be possible.
Comment 9 Paul Leacu 2013-09-23 13:57:57 EDT
See Comment 8 - no issue (from component tech lead).

Note You need to log in before you can comment on or make changes to this bug.