Bug 1008635 - [abrt] firewall-config-0.3.4-1.fc20: firewall-config:1588:onChangeZone:TypeError: 'NoneType' object is not iterable
[abrt] firewall-config-0.3.4-1.fc20: firewall-config:1588:onChangeZone:TypeEr...
Status: CLOSED DUPLICATE of bug 962398
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
abrt_hash:18ab4994451009ddbff11666bd4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 13:53 EDT by Igor Gnatenko
Modified: 2013-09-17 04:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-17 04:40:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (657 bytes, text/plain)
2013-09-16 13:53 EDT, Igor Gnatenko
no flags Details
File: environ (1.34 KB, text/plain)
2013-09-16 13:54 EDT, Igor Gnatenko
no flags Details

  None (edit)
Description Igor Gnatenko 2013-09-16 13:53:53 EDT
Version-Release number of selected component:
firewall-config-0.3.4-1.fc20

Additional info:
reporter:       libreport-2.1.7
cmdline:        /usr/bin/python /usr/bin/firewall-config
executable:     /usr/bin/firewall-config
kernel:         3.11.0-300.fc20.x86_64
runlevel:       unknown
type:           Python
uid:            1000

Truncated backtrace:
firewall-config:1588:onChangeZone:TypeError: 'NoneType' object is not iterable

Traceback (most recent call last):
  File "/usr/bin/firewall-config", line 1588, in onChangeZone
    for item in ports:
TypeError: 'NoneType' object is not iterable

Local variables in innermost frame:
masquerade: None
name: 'vnc-server'
_services: []
default: False
interfaces: ['wlp3s0']
args: (<TreeSelection object at 0x313a9b0 (GtkTreeSelection at 0x2cc14d0)>,)
iter: None
self: <__main__.FirewallConfig object at 0x2bed610>
sources: []
builtin: False
icmpblocks: []
rules: []
services: ['mdns', 'dhcpv6-client', 'ssh']
active_zone: 'public'
ports: None
forward_ports: []
Comment 1 Igor Gnatenko 2013-09-16 13:53:57 EDT
Created attachment 798381 [details]
File: backtrace
Comment 2 Igor Gnatenko 2013-09-16 13:54:00 EDT
Created attachment 798382 [details]
File: environ
Comment 3 Jiri Popelka 2013-09-17 04:40:21 EDT
hmm, another mysterious None-returning-function bug.
This time it (seems to) was FirewallClient.getPorts()

*** This bug has been marked as a duplicate of bug 962398 ***

Note You need to log in before you can comment on or make changes to this bug.