Bug 1008760 - Starting with kernel-PAE-3.12.0-0.rc0.git24.1.fc21.i686 using radeon.agpmode=-1 blocks kms which blocks X
Starting with kernel-PAE-3.12.0-0.rc0.git24.1.fc21.i686 using radeon.agpmode=...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 23:12 EDT by Bruno Wolff III
Modified: 2013-09-29 23:13 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-29 23:13:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kdm log output (44.87 KB, text/plain)
2013-09-18 23:13 EDT, Bruno Wolff III
no flags Details
X log output (18.78 KB, text/plain)
2013-09-18 23:14 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2013-09-16 23:12:40 EDT
Description of problem:
When booting with kernel-PAE-3.12.0-0.rc0.git25.1.fc21.i686 or kernel-PAE-3.12.0-0.rc0.git26.2.fc21.i686 (nodebug repo) the text size does not switch during the boot process as is normal and neither kdm nor lxdm will start a graphical session. When I boot using kernel-PAE-3.12.0-0.rc0.git22.2.fc21.i686 things work as expected. I tried downgrading dracut and rebuilding the initramfs for git26, but that didn't help.

My video card is an rv280 based card. The attached monitor doesn't do EDID properly and I an xorg.conf file to set a nice mode.

I also have an x86_64 system with an rv530 based card that runs kernel-3.12.0-0.rc0.git26.2.fc21.x86_64 without any video related issues.
Comment 1 Bruno Wolff III 2013-09-16 23:14:47 EDT
The x86_64 system is really f20 with a nodebug rawhide kernel, the i686 system is a normal rawhide system.
Comment 2 Bruno Wolff III 2013-09-17 19:13:12 EDT
I am still seeing this with kernel-PAE-3.12.0-0.rc1.git0.1.fc21.i686. 
I am using systemd-207-3 now, but that doesn't seem to make a difference either way.
Comment 3 Bruno Wolff III 2013-09-18 23:11:46 EDT
The problem existed with kernel-PAE-3.12.0-0.rc0.git24.1.fc21. git23 failed to build in koji, so I can test that one.
The problem still exists with kernel-PAE-3.12.0-0.rc1.git2.1.fc21.
I'm going to attach some logs from X and kdm that might shed a bit more light on things.
Comment 4 Bruno Wolff III 2013-09-18 23:13:07 EDT
Created attachment 799724 [details]
kdm log output
Comment 5 Bruno Wolff III 2013-09-18 23:14:15 EDT
Created attachment 799725 [details]
X log output
Comment 6 Bruno Wolff III 2013-09-18 23:16:38 EDT
In comment 3, that should have been that I can't test the git23 build.
Comment 7 Bruno Wolff III 2013-09-21 03:30:53 EDT
It looks like this is related to using radeon.agpmode=-1 as a boot parameter. I need this because of bug 662312, which seems to still affect me.
Comment 8 Bruno Wolff III 2013-09-21 03:35:36 EDT
When I booted without radeon.agpmode=-1 I didn't have the problem with kms not working (blocking X from started), but shortly after logging into to xfce, all I could do was move the mouse pointer around which was a symptom of bug 662312. I hadn't tested that bug in quite a while, but it does still seem to be a problem.
Comment 9 Bruno Wolff III 2013-09-21 12:24:27 EDT
I ran git whatchanged d5d04bb..3711d86 which I think should list the changes between git22 and git24 and I didn't see any that looked like radeon graphics driver changes. There were some PCI changes and maybe one of those broken using the radeon driver in PCI mode as a side effect.
Comment 10 Bruno Wolff III 2013-09-21 12:40:56 EDT
I filed an upstream bug for this (https://bugzilla.kernel.org/show_bug.cgi?id=61811).
Comment 11 Bruno Wolff III 2013-09-26 08:39:11 EDT
Another error message that seems to be related that is showing up in dmesg output is "radeon: `-1' invalid for parameter `agpmode'".

Also, after a bit of learning, I am working at doing a bisect to find the commit that changed the behavior. If I don't run into any problems, I'll probably be done on Monday.
Comment 12 Bruno Wolff III 2013-09-27 20:05:39 EDT
Turns out this is an argument parsing bug, not a video driver bug. At least one other person reported a similar problem with a totally different type of device.

I tested a proposed fix against 3.12-rc2 and it works. I'll close this once I see the fix show up in Fedora. I think we can let it flow in normally unless other people start having trouble as well.

(The issue was with a change from strict_strto*() to kstrto*() that had some mistakes in it. The fix was posted on a powerpc list. You can look at the upstream bug for more info.)
Comment 13 Bruno Wolff III 2013-09-29 00:55:30 EDT
Commit 3a126f85e015701e56240884f27f97543580d5f7, which fixes this, is now in Linus' tree.
Comment 14 Bruno Wolff III 2013-09-29 23:13:04 EDT
This is fixed in kernel-PAE-3.12.0-0.rc2.git4.1.fc21.i686.

Note You need to log in before you can comment on or make changes to this bug.