Bug 1008788 - text install fails - reboots after completing all spokes and hitting 'c'
text install fails - reboots after completing all spokes and hitting 'c'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F20AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-09-17 01:11 EDT by Andre Robatino
Modified: 2013-10-05 21:03 EDT (History)
12 users (show)

See Also:
Fixed In Version: anaconda-20.18-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-05 21:03:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of netinst install with 20 Alpha RC3 (18.94 KB, image/png)
2013-09-17 11:23 EDT, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2013-09-17 01:11:23 EDT
Description of problem:
Using any of the 20 Alpha RC3 install images (32- or 64-bit, DVD or netinst), text install fails after completing all spokes and hitting 'c'. Instead of beginning the install, it reboots. I tested both minimal and default GNOME installs. Minimal GUI install seems to work okay (at least it didn't reboot after hitting the button to begin installation).

Version-Release number of selected component (if applicable):
anaconda-20.17-1

How reproducible:
always

Steps to Reproduce:
1. using text install, complete all spokes
2. hit 'c' to begin installation

Actual results:
reboots

Expected results:
should install
Comment 1 Andre Robatino 2013-09-17 01:15:21 EDT
Proposing as Alpha Blocker according to https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Installation_interfaces : "When using the dedicated installer images, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces."
Comment 2 Andre Robatino 2013-09-17 01:32:05 EDT
Should have mentioned that this worked fine in 20 Alpha RC2 (with anaconda-20.15-1).
Comment 3 Petr Schindler 2013-09-17 04:22:36 EDT
I can confirm this. It's regression from RC2. +1 blocker
Comment 4 Jaroslav Reznik 2013-09-17 06:16:50 EDT
To speed up blocker acceptance process, confirmed, +1 blocker. Vratislav, thanks for quick patch!
Comment 5 Jóhann B. Guðmundsson 2013-09-17 07:13:21 EDT
+1 blocker
Comment 6 Petr Schindler 2013-09-17 07:39:52 EDT
Fix works for me. I'm able to process through the installation with it.

We have +3 blocker now. I'm moving it to accepted.
Comment 7 Andre Robatino 2013-09-17 11:23:23 EDT
Created attachment 798864 [details]
screenshot of netinst install with 20 Alpha RC3

When I was installing from the netinsts, I saw that yum error again (screenshot attached). Don't know if it's related, and upon refreshing the spokes all showed [x], after which I hit 'c' and generated the reboot.
Comment 8 Vratislav Podzimek 2013-09-17 11:37:32 EDT
(In reply to Andre Robatino from comment #7)
> Created attachment 798864 [details]
> screenshot of netinst install with 20 Alpha RC3
> 
> When I was installing from the netinsts, I saw that yum error again
> (screenshot attached). Don't know if it's related, and upon refreshing the
> spokes all showed [x], after which I hit 'c' and generated the reboot.
I saw it too even with my patch applied byt it seems to be unrelated and not causing any issues.
Comment 9 Paul Whalen 2013-09-17 18:57:45 EDT
This also occurs when doing a kickstart installations, the pre-completed spokes appear briefly before the system is rebooted.
Comment 10 Petr Schindler 2013-09-19 04:06:55 EDT
This bug seems to be fixed on 20.18-1
Comment 11 Andre Robatino 2013-10-05 21:03:43 EDT
Closing since this went to stable.

Note You need to log in before you can comment on or make changes to this bug.