Bug 10088 - Only LUN 0 is seen on each if my HBA's
Summary: Only LUN 0 is seen on each if my HBA's
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-09 14:46 UTC by stan_schembri
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-26 17:45:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description stan_schembri 2000-03-09 14:46:48 UTC
I have two qlogic 2100 fibre channel adapters connected to a Mylex Raid
Controller fibre channel expansion unit. When I create arrays LINUX only
ever detects the array assigned LUN 0 on each HBA. Does LINUX support
multiple HBAs?

Comment 1 Adam Thompson 2000-07-26 17:45:30 UTC
Yes, multiple-LUN support exists.
Option 1) recompile kernel with multiple LUN support
Option 2) add a parameter to the boot commandline (through LILO)
 - I can't find the parameter documented anywhere, though.

BTW: best way I've found to update the kernel under RH6.2 is to install the 
kernel-2.2.16-3.src.rpm, extract with 'rpm -bp', then go modify the config file 
that corresponds to whichever version you'll be using (i686-smp, for example), 
then go back and use 'rpm -bb' to rebuild the RPM(s).  [Warning: takes a long 
time, because it builds eight(?) versions of the kernel]


Comment 2 Alan Cox 2000-08-22 18:52:07 UTC
max_scsi_luns=8


Note You need to log in before you can comment on or make changes to this bug.