Bug 100880 - Any user can reboot or shut down the system
Any user can reboot or shut down the system
Status: CLOSED DUPLICATE of bug 99216
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-session (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-26 09:49 EDT by Marcos F. Villa
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcos F. Villa 2003-07-26 09:49:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030530 Galeon/1.3.5

Description of problem:
When you finally get into the system and are ready to log in you've different
choices to take, between some others:
1 - Restart System
2 - Shut down

Any user who access the system is able to restart or shut down the system, I'm
not sure if there's a way to change it, my machine used to crash after 1 minute
of started the graphical interface.

Also when you login into the X and try to log out the system crashes and doesn't
respond to keyboard.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. When the system displays the login information, where you should complete
your username and password
2.
3.
    

Actual Results:  any user could restart or shutdown the system

Expected Results:  Only admin users, or users with some privileges should do it.

Additional info:
Comment 1 Havoc Pennington 2003-07-27 20:29:26 EDT
The reboot issue isn't a bug, you are only given those permissions if you 
are on the console (where you could just push the power button or Ctrl+Alt+Del
anyway, or unplug the computer). Also the reboot/shutdown items will vanish 
if you configure the system so users can't reboot, probably google will 
turn up instructions for that pretty quickly.

The gnome-session crash is a separate bug, it's probably already filed 
but we need to verify that it is. Please try to report only one issue
per bug, as each bug needs to be separately tracked and get its own 
resolution.
Comment 2 Havoc Pennington 2003-08-07 17:34:47 EDT
99216, 100507 are other reports of the logout crash, so closing this bug. 

*** This bug has been marked as a duplicate of 99216 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:57:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.