Bug 1008823 - Enable and disable feature of console for RA connection definitions and admin objects are broken
Enable and disable feature of console for RA connection definitions and admin...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity unspecified
: ER3
: EAP 6.2.0
Assigned To: Heiko Braun
Jakub Cechacek
Russell Dickenson
:
Depends On:
Blocks: 1003533
  Show dependency treegraph
 
Reported: 2013-09-17 02:58 EDT by Osamu Nagano
Modified: 2015-02-01 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:49:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
onagano: needinfo+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker HAL-199 Major Resolved Enable and disable feature of console for RA connection definitions and admin objects are broken 2013-11-12 05:48:07 EST

  None (edit)
Description Osamu Nagano 2013-09-17 02:58:48 EDT
Description of problem:
Enable and Disable buttons of [Profile > Resource Adapters > View > Connection Definitions] (and Admin Objects too) send requests with wrong addresses. It results in an unknown error message with the following contents.

--
Unexpected HTTP response: 500

Request
{
    "address" => [
        ("subsystem" => "resource-adapters"),
        ("resource-adapter" => "wmq.jmsra.rar"),
        ("connection-definitions" => "java:jboss/MQQueueCONNECTIONFACTORY")
    ],
    "operation" => "write-attribute",
    "name" => "enabled",
    "value" => true
}

Response

Internal Server Error
{
    "outcome" => "failed",
    "failure-description" => "JBAS014807: Management resource '[
    (\"subsystem\" => \"resource-adapters\"),
    (\"resource-adapter\" => \"wmq.jmsra.rar\"),
    (\"connection-definitions\" => \"java:jboss/MQQueueCONNECTIONFACTORY\")
]' not found",
    "rolled-back" => true,
    "response-headers" => {"process-state" => "reload-required"}
}
--

Path values of connection-definitions and admin-objects are just their names, not JNDI names, like this.

--
/subsystem=resource-adapters/resource-adapter=wmq.jmsra.rar/connection-definitions=MQQueueCONNECTIONFACTORY:write-attribute(name=enabled,value=false)
--
Comment 1 Osamu Nagano 2013-09-17 03:02:21 EDT
Deployable RAR file, TestCase.zip, is available as an attachment in case 00944733, though it's a little bit large.
Comment 2 Heiko Braun 2013-09-17 06:26:25 EDT
I cannot reproduce the issue. Noty on EAP 6.1.1 and not on 6.x (development)
Comment 3 JBoss JIRA Server 2013-09-17 21:36:54 EDT
Osamu Nagano <onagano@redhat.com> made a comment on jira HAL-199

I attached a reproducer, which contains those.
- standalone/configuration/standalone-full-ibmmq.xml
- standalone/deployments/wmq.jmsra.rar
- standalone/deployments/wmq.jmsra.rar.dodeploy

Unzip and overlay the attachment and start standalone.sh with "-c standalone-full-ibmmq.xml" option.  It will deploy a RAR file and try to en/disable it on [Profile > Resource Adapters > View > Connection Definitions] page.
Comment 4 Osamu Nagano 2013-09-17 21:42:23 EDT
I attached a reproducer in JIRA.  It must work on EAP 6.1.1.  Please let me know if anything.
Comment 5 JBoss JIRA Server 2013-09-18 03:38:13 EDT
Heiko Braun <ike.braun@googlemail.com> updated the status of jira HAL-199 to Coding In Progress
Comment 6 JBoss JIRA Server 2013-09-18 03:38:29 EDT
Heiko Braun <ike.braun@googlemail.com> made a comment on jira HAL-199

Thanks, that does the job. I can now see the problem.
Comment 7 JBoss JIRA Server 2013-09-18 04:00:56 EDT
Heiko Braun <ike.braun@googlemail.com> updated the status of jira HAL-199 to Resolved
Comment 8 Jan Stefl 2013-09-27 05:56:35 EDT
6.2.0-ER3 verified - PASSED
I was able enable / disable "MQQueueCONNECTIONFACTORY" from reproducer.

Note You need to log in before you can comment on or make changes to this bug.